Skip to main content

Mopidy extension for playing music from Spotify

Project description

Latest PyPI version Number of PyPI downloads Travis CI build status Test coverage

Mopidy extension for playing music from Spotify.

Dependencies

  • A Spotify Premium subscription. Mopidy-Spotify will not work with Spotify Free or Spotify Unlimited, just Spotify Premium.
  • libspotify >= 12, < 13. The official C library from the Spotify developer site. The package is available as libspotify12 from apt.mopidy.com.
  • pyspotify >= 1.9, < 2. The libspotify python wrapper. The package is available as python-spotify from apt.mopidy.com or pyspotify on PyPI.

If you install Mopidy-Spotify from apt.mopidy.com, these dependencies are installed automatically.

Installation

Install by running:

pip install Mopidy-Spotify

Or, if available, install the Debian/Ubuntu package from apt.mopidy.com.

Configuration

Before starting Mopidy, you must add your Spotify Premium username and password to your Mopidy configuration file:

[spotify]
username = alice
password = secret

The following configuration values are available:

  • spotify/enabled: If the Spotify extension should be enabled or not.
  • spotify/username: Your Spotify Premium username.
  • spotify/password: Your Spotify Premium password.
  • spotify/bitrate: Audio bitrate in kbps. 96, 160 or 320. Defaults to 160.
  • spotify/timeout: Seconds before giving up waiting for search results, etc. Defaults to 10 seconds.
  • spotify/cache_dir: The dir where the Spotify extension caches data. Defaults to $XDG_CACHE_DIR/mopidy/spotify, which usually means ~/.cache/mopidy/spotify.

Changelog

v0.1.0 (UNRELEASED)

  • Moved extension out of the main Mopidy project.

Project details


Supported by

Elastic Elastic Search Pingdom Pingdom Monitoring Google Google BigQuery Sentry Sentry Error logging AWS AWS Cloud computing DataDog DataDog Monitoring Fastly Fastly CDN DigiCert DigiCert EV certificate StatusPage StatusPage Status page