Skip to main content
https://github.com/horazont/aiosasl/workflows/CI/badge.svg https://coveralls.io/repos/github/horazont/aiosasl/badge.svg?branch=devel

aiosasl provides a generic, asyncio-based SASL library. It can be used with any protocol, provided the neccessary interface code is provided by the application or protocol implementation.

Dependencies

  • Python ≥ 3.5

Supported SASL mechanisms

  • PLAIN: authenticate with plaintext password (RFC 4616)

  • ANONYMOUS: anonymous “authentication” (RFC 4505)

  • SCRAM-SHA-1 and SCRAM-SHA-256 (and the -PLUS variants with channel binding): Salted Challenge Response Authentication (RFC 5802)

Documentation

Official documentation can be built with sphinx and is available online on our servers.

Supported channel binding methods

  • tls-unique and tls-server-end-point with a pyOpenSSL connection

  • all methods supported by the Python standard library when using the ssl module

Metadata

Release files for aiosasl 0.5.0

For a detailed explanation of source distributions (sdists) and built distributions (wheels), please see the package formats documentation.

Source distribution (sdist)

Source distribution for aiosasl 0.5.0
File Size Uploaded
aiosasl-0.5.0.tar.gz 28.3 kB Details

Release files / aiosasl-0.5.0.tar.gz

Download URL aiosasl-0.5.0.tar.gz
Size 28.3 kB
Tags Source
SHA-256 checksum
How to use checksums
d927a8f9d855c4c00dea9d88fb86ea0d09dd4e7642b2109d2bd93be2f4c17b4e
BLAKE2b-256 checksum
How to use checksums
eb6e5f6251bedc307c7f56d9d94447e9624d9dbbeac9669d74d30d02f2b10f6e
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
No
Uploaded via twine/3.2.0 pkginfo/1.4.2 requests/2.24.0 setuptools/50.3.0 requests-toolbelt/0.8.0 tqdm/4.51.0 CPython/3.9.1

Release history Release notifications | RSS feed

This release

0.5.0 This release

1 release file

0.4.1

1 release file

0.4.0

1 release file

0.3.1

1 release file

0.3.0

1 release file

0.2.1

1 release file

0.2.0

1 release file

0.1.1

1 release file

0.1.0

Anthropic, PBC Visionary sponsor Bloomberg Visionary sponsor Hudson River Trading Visionary sponsor Meta Visionary sponsor NVIDIA Visionary sponsor Microsoft Sustainability sponsor Depot Continuous Integration AWS Cloud computing and Security Sponsor Datadog Monitoring Fastly CDN Google Download Analytics Sentry Error logging StatusPage Status page