Skip to main content

Provider package apache-airflow-providers-elasticsearch for Apache Airflow

Project description

Package apache-airflow-providers-elasticsearch

Release: 1.0.3

Elasticsearch

Provider package

This is a provider package for elasticsearch provider. All classes for this provider package are in airflow.providers.elasticsearch python package.

You can find package information and changelog for the provider in the documentation.

Installation

NOTE!

On November 2020, new version of PIP (20.3) has been released with a new, 2020 resolver. This resolver does not yet work with Apache Airflow and might lead to errors in installation - depends on your choice of extras. In order to install Airflow you need to either downgrade pip to version 20.2.4 pip install --upgrade pip==20.2.4 or, in case you use Pip 20.3, you need to add option --use-deprecated legacy-resolver to your pip install command.

You can install this package on top of an existing airflow 2.* installation via pip install apache-airflow-providers-elasticsearch

PIP requirements

PIP package Version required
elasticsearch-dbapi ==0.1.0
elasticsearch-dsl >=5.0.0
elasticsearch >7, <7.6.0

Project details


Download files

Download the file for your platform. If you're not sure which to choose, learn more about installing packages.

Source Distribution

Built Distribution

Supported by

AWS AWS Cloud computing Datadog Datadog Monitoring Facebook / Instagram Facebook / Instagram PSF Sponsor Fastly Fastly CDN Google Google Object Storage and Download Analytics Huawei Huawei PSF Sponsor Microsoft Microsoft PSF Sponsor NVIDIA NVIDIA PSF Sponsor Pingdom Pingdom Monitoring Salesforce Salesforce PSF Sponsor Sentry Sentry Error logging StatusPage StatusPage Status page