Skip to main content

Provides tools for creating abstractions and wrappers

Project description

Info:Provides tools for creating high-level abstractions and wrappers
Repository:https://github.com/ArroyoNetworks/python-arroyo
Author(s):Matthew Ellison (http://github.com/seglberg)
Maintainer(s):Matthew Ellison (http://github.com/seglberg)
https://travis-ci.org/ArroyoNetworks/python-arroyo.svg?branch=master https://img.shields.io/codecov/c/github/ArroyoNetworks/python-arroyo/master.svg?maxAge=600

Introduction

This package is essentially a namespace for plugins to register additional abstractions, wrappers, and utilities.

However, basic “helper” functions are provided in the utils module.

Installation

This package is available on PyPI:

$ pip install arroyo

Note

However, unless you are developing a plugin, direct installation of this package is typically not desired.

Dependencies

Python>=3.5:The minimum version of Python is 3.5 to ensure that all plugins have 3.5 features available.

Required

None. This package is left dependency free on purpose.

Plugins

The following is a list of available plugins:

arroyo-crypto:High level abstraction for x509 and asymmetric keys. Here

Project details


Download files

Download the file for your platform. If you're not sure which to choose, learn more about installing packages.

Filename, size & hash SHA256 hash help File type Python version Upload date
arroyo-1.3.0.post2.tar.gz (21.2 kB) Copy SHA256 hash SHA256 Source None Mar 3, 2018

Supported by

Elastic Elastic Search Pingdom Pingdom Monitoring Google Google BigQuery Sentry Sentry Error logging AWS AWS Cloud computing DataDog DataDog Monitoring Fastly Fastly CDN DigiCert DigiCert EV certificate StatusPage StatusPage Status page