Skip to main content
Help us improve PyPI by participating in user testing. All experience levels needed!

Determine what projects are blocking you from porting to Python 3

Project description

This script takes in a set of dependencies and then figures out which of them are holding you up from porting to Python 3.

You can specify your dependencies in multiple ways:

caniusepython3 -r requirements.txt
caniusepython3 -m PKG-INFO
caniusepython3 -p numpy,scipy,ipython
# If your project's setup.py uses setuptools ...
python setup.py caniusepython3

The output of the script will tell you how many (implicit) dependencies you need to transition to Python 3 in order to allow you to make the same transition. It will also list what projects have no explicit dependency blocking their transition so you can ask them consider starting a port to Python 3.

Project details


Release history Release notifications

History Node

7.0.0

History Node

6.0.0

History Node

5.0.0

History Node

4.0.0

History Node

3.4.1

History Node

3.4.0

History Node

3.3.0

History Node

3.2.0

History Node

3.1.0

History Node

3.0.0

History Node

2.2.0

History Node

2.1.2

History Node

2.1.1

History Node

2.1.0

History Node

2.0.3

History Node

2.0.2

History Node

2.0.1

History Node

2.0.0

History Node

1.2.1

History Node

1.2.0

This version
History Node

1.1.0

History Node

1.0

Download files

Download the file for your platform. If you're not sure which to choose, learn more about installing packages.

Filename, size & hash SHA256 hash help File type Python version Upload date
caniusepython3-1.1.0-py2.py3-none-any.whl (16.3 kB) Copy SHA256 hash SHA256 Wheel py2.py3 Feb 28, 2014
caniusepython3-1.1.0.tar.gz (13.0 kB) Copy SHA256 hash SHA256 Source None Feb 28, 2014

Supported by

Elastic Elastic Search Pingdom Pingdom Monitoring Google Google BigQuery Sentry Sentry Error logging CloudAMQP CloudAMQP RabbitMQ AWS AWS Cloud computing Fastly Fastly CDN DigiCert DigiCert EV certificate StatusPage StatusPage Status page