Skip to main content

Enables a IE6 warning message instructing the user to download a newer (and better) browser.(Based on efforts initiated by http://www.ie6nomore.com/)

Project description

collective.ui.ie6nomore

Overview

Enough is enough. Microsoft Internet Explorer 6 was released in late 2001. For its time, it was a decent browser, but in 2009, it is still in use by a significant portion of the web population, and its time is now up.

This is a Plone 3 implementation of the code available at http://www.ie6nomore.com/.

Embrace this campaign, support this noble cause.

Installation

To use this package, on a buildout based installation:

1. Unpack collective.ui.ie6nomore package to src/ folder of your buildout 2. Edit your buildout.cfg and add the following information:

[buildout]
...
eggs =
    collective.ui.ie6nomore

[instance]
zcml =
    ...
    collective.ui.ie6nomore

The last line tells buildout to generate a zcml snippet that tells Zope to configure collective.ui.ie6nomore.

If another package depends on the collective.ui.ie6nomore egg or includes its zcml directly you do not need to specify anything in the buildout configuration: buildout will detect this automatically.

After updating the configuration you need to run the ‘’bin/buildout’‘, which will take care of updating your system.

Go to the ‘Site Setup’ page in the Plone interface and click on the ‘Add/Remove Products’ link.

Choose the product (check its checkbox) and click the ‘Install’ button.

Uninstall – This can be done from the same management screen, but only if you installed it from the quick installer.

Note: You may have to empty your browser cache to see the effects of the product installation.

Browsers and OS’s

  • Internet Explorer 6.0 (WinXP/Vista) ()
  • Internet Explorer 8.0 (WinXP/Vista)
  • Internet Explorer 7.0 (WinXP/Vista)
  • Firefox 3 (WinXP/Vista/MacOSX)
  • Safari 3 (WinXP/Vista/MacOSX)

Credits

  • Erico Andrei (products at simplesconsultoria dot com dot br) - Packaging

Changelog

1.0 - (2009-08-04)

  • Localization support [erico_andrei]
  • Based on sniplet available at http://www.ie6nomore.com/ [erico_andrei]
  • Initial release of collective.ui.ie6nomore [erico_andrei]

Project details


Release history Release notifications

This version
History Node

1.0

Download files

Download the file for your platform. If you're not sure which to choose, learn more about installing packages.

Filename, size & hash SHA256 hash help File type Python version Upload date
collective.ui.ie6nomore-1.0-py2.4.egg (19.3 kB) Copy SHA256 hash SHA256 Egg 2.4
collective.ui.ie6nomore-1.0.tar.gz (13.9 kB) Copy SHA256 hash SHA256 Source None

Supported by

Elastic Elastic Search Pingdom Pingdom Monitoring Google Google BigQuery Sentry Sentry Error logging AWS AWS Cloud computing DataDog DataDog Monitoring Fastly Fastly CDN SignalFx SignalFx Supporter DigiCert DigiCert EV certificate StatusPage StatusPage Status page