Skip to main content
This is a pre-production deployment of Warehouse. Changes made here affect the production instance of PyPI (pypi.python.org).
Help us improve Python packaging - Donate today!

A block for ftw.simplelayout

Project Description

Introduction

This package is an addon for ftw.simplelayout. Please make sure you already installed ftw.simplelayout on your plone site before installing this addon.

ftw.iframeblock privides a block for ftw.simplelayout, which renders a iframe using iframe-resizer. Read the setup instructions of iframeresizer carefully: you need an implementation on both domains.

Linking to sub pages

When integrating other websites in iframes and indexing those contents in the search, we want to be able to link from the search to a specific iframed sub-page.

In order to make this possible we need to be able to pass the requested sub-page as GET request param.

For security reason, the origin of both URLs must be the same, otherwise the configured startpage is loaded.

Examples:

  • http://localhost:8080/Plone/the-page?i=http://foo.ch/bar/baz.php
  • http://localhost:8080/Plone/the-page?i_iframeblock2=http://foo.ch/bar/baz.php

Compatibility

Runs with Plone 4.3.x.

Installation local development-environment

$ git clone git@github.com:4teamwork/ftw.iframeblock.git
$ cd ftw.iframeblock
$ ln -s development.cfg buildout.cfg
$ python2.7 bootstrap.py
$ bin/buildout
$ bin/instance fg

Changelog

1.3.4 (2017-07-25)

  • Enable scrolling fallback when the iframe resizer is disabled. [lknoepfel]
  • Make iframe fixes compatible with ftw.iframefix 2.0. [Kevin Bieri]
  • Install ftw.iframefix [Kevin Bieri]

1.3.3 (2017-03-07)

  • Make IFrameBlock addable on plone site per default [raphael-s]

1.3.2 (2017-01-17)

  • Arghhh the js part should now remove the loading css class from the prev. element. [mathias.leimgruber]

1.3.1 (2017-01-17)

  • Well… implement IE compatible spinner, which does not changes the bg color of the iframe. [mathias.leimgruber]

1.3.0 (2017-01-10)

  • Implement spinner while loading the iframe. [mathias.leimgruber]

1.2.0 (2016-12-13)

  • Remove ftw.simplelayout mapblock dependency. [mathias.leimgruber]

1.1.0 (2016-10-04)

  • Allow opening sub-page by passing it as GET parameter “i”. [jone]
  • Update description of edit view. [raphael-s]

1.0.3 (2016-08-09)

  • Remove metadata.xml-dependencie to ftw.simplelayout. This package is an addon of ftw.simplelayout and should not install it. [elioschmutz]

1.0.2 (2016-07-08)

  • Add support for IE11 and MS Edge. [raphael schwob]

1.0.1 (2016-06-20)

  • Init implementation. [raphael schwob]
Release History

Release History

This version
History Node

1.3.4

History Node

1.3.3

History Node

1.3.2

History Node

1.3.1

History Node

1.3.0

History Node

1.2.0

History Node

1.1.0

History Node

1.0.3

History Node

1.0.2

History Node

1.0.1

Download Files

Download Files

Download the file for your platform. If you're not sure which to choose, learn more about installing packages.

File Name & Checksum SHA256 Checksum Help Version File Type Upload Date
ftw.iframeblock-1.3.4.tar.gz (26.0 kB) Copy SHA256 Checksum SHA256 Source Jul 25, 2017

Supported By

WebFaction WebFaction Technical Writing Elastic Elastic Search Pingdom Pingdom Monitoring Dyn Dyn DNS Sentry Sentry Error Logging CloudAMQP CloudAMQP RabbitMQ Heroku Heroku PaaS Kabu Creative Kabu Creative UX & Design Fastly Fastly CDN DigiCert DigiCert EV Certificate Rackspace Rackspace Cloud Servers DreamHost DreamHost Log Hosting