Skip to main content

gpsd client library (python3 port)

Project description

## gpsd-python3
----

Simple port of the official GPSD project libraries to a separate package.

Python files match the 3.17 release, and if conflicts arise, the [ GPSD Project ]( http://www.catb.org/gpsd/ ) will be more up-to-date.

## Motivation

The GPSD project has supported python2 for many years, but python3 support is
much more recent. Unfortunately, because GPSD uses SCons as its build system,
building with, and installing client libraries for python 3 requires scons 3.0+.

Until such support is more widespread, this package provides an appropriate stop-gap.

Use this package if you:
1. Use GPSD client libraries
2. Implement in python 3;
3. have one of the following:
- Don't need a full gpsd install, just the client libraries
- Running Ubuntu 17.10 or lower
- Otherwise have SCons 3.0 or lower installed

If you don't have one of these situations, the Official GPSD project will probably
satisfy your needs.

----
All code is covered under the BSD license with rights assigned to the GPSD Project.

Project details


Download files

Download the file for your platform. If you're not sure which to choose, learn more about installing packages.

Filename, size & hash SHA256 hash help File type Python version Upload date
gps_py3_shim-3.17.5.tar.gz (22.4 kB) Copy SHA256 hash SHA256 Source None

Supported by

Elastic Elastic Search Pingdom Pingdom Monitoring Google Google BigQuery Sentry Sentry Error logging AWS AWS Cloud computing DataDog DataDog Monitoring Fastly Fastly CDN SignalFx SignalFx Supporter DigiCert DigiCert EV certificate StatusPage StatusPage Status page