Grammars suitable for lark parser:
mime.lark: MIME Media Typespalindrome.lark: palindrome is a word, number, or other sequence of characters which reads the same backward as forward, such asmadamorracecaror the number10801.tap13.lark: TAP13 - The Test Anything Protocol v13subunit_v1.lark: SubUnit v1 - SubUnit v1 protocolbc.lark: bc, an arbitrary precision calculator languagerobotstxt.lark: robots.txtpf.lark: OpenBSD packet filter configuration fileregex.lark: POSIX Regular Expressionsrfc_822.lark: RFC 822: Standard for ARPA Internet Text Messagesrfc_1738.lark: RFC 1738: Uniform Resource Locators (URL) (WIP)rfc_2396.lark: RFC 2396: Uniform Resource Identifiers (URI)rfc_2397.lark: RFC 2397: The "data" URL schemerfc_5545.lark: RFC 5545: Internet Calendaring and Scheduling Core Object Specification (iCalendar)rfc_6531.lark: RFC 6531: SMTP Extension for Internationalized Email (WIP)rfc_5321.lark: RFC 5321: Simple Mail Transfer Protocol (WIP)toml.lark: Tom's Obvious, Minimal Languageyaml.lark: YAML: YAML Ain't Markup Languagerestructuredtext.larksqlite.larkgedcom.larkpostal.larkphone_number.lark
How-To Use:
$ python3 -m venv venv
$ pip3 install lark_grammars
$ cat example.py
from lark_grammars import grammars
grammars.grammar_files['bc']
$ python3 generate.py --grammar grammars/tap13.lark
TAP version 13
1..861602252
not ok # Skipped
# - C o A 2 1 H
See grammars for other parsers:
Metadata
Release files for lark-grammars 0.3.0
For a detailed explanation of source distributions (sdists) and built distributions (wheels), please see the package formats documentation.
Source distribution (sdist)
| File | Size | Uploaded | Provenance | Actions |
|---|---|---|---|---|
| lark-grammars-0.3.0.tar.gz | 47.7 kB | Without provenance | Details for lark-grammars-0.3.0.tar.gz |
Built distribution (wheel)
| File | Interpreter | ABI | Platform | Actions Reset |
|---|---|---|---|---|
| lark_grammars-0.3.0-py3-none-any.whl | Python 3 | none | any | Details for lark_grammars-0.3.0-py3-none-any.whl |
Total release size: 100.7 kB
Release files / lark-grammars-0.3.0.tar.gz
| Download URL | lark-grammars-0.3.0.tar.gz |
|---|---|
| Size | 47.7 kB |
| Tags | Source |
|
SHA-256 checksum How to use checksums |
fab89475a68048d513d9e49d8c50d99156c5e60c62e2c806a8c0f945979b39bc
|
|
BLAKE2b-256 checksum How to use checksums |
eacd368a0ed4723742640e20d4a1a28601983e9c76aecf536e7b0821f02283d1
|
| Upload date | |
|
Uploaded using Trusted Publishing? What is trusted publishing? |
No |
| Uploaded via |
twine/3.2.0 pkginfo/1.5.0.1 requests/2.22.0 setuptools/45.2.0 requests-toolbelt/0.9.1 tqdm/4.48.2 CPython/3.8.2
|
Release files / lark_grammars-0.3.0-py3-none-any.whl
| Download URL | lark_grammars-0.3.0-py3-none-any.whl |
|---|---|
| Size | 53.0 kB |
| Tags | Python 3 |
|
SHA-256 checksum How to use checksums |
da5b2e4951f6f0c4ae172c661ec9c0f9eb3c773676c0c381e1b397d43d857208
|
|
BLAKE2b-256 checksum How to use checksums |
c6819f07dc97fb647d4b43b0710604db60998d66c26f400adc1ca0234446c9ba
|
| Upload date | |
|
Uploaded using Trusted Publishing? What is trusted publishing? |
No |
| Uploaded via |
twine/3.2.0 pkginfo/1.5.0.1 requests/2.22.0 setuptools/45.2.0 requests-toolbelt/0.9.1 tqdm/4.48.2 CPython/3.8.2
|
Security for lark-grammars 0.3.0
Provenance
Provenance describes where a file came from. On PyPI, provenance is shared via attestations, which provide a verifiable record of the build or publishing details. View details, limitations and caveats.
No provenance found
None of the files in this release were uploaded with provenance metadata.
A note on package security
PyPI is a repository for distributing packages, not a service for auditing them. While third-party security researchers and our staff do their best to detect and remove malicious packages, PyPI cannot guarantee the quality, security or suitability of any given package.
To learn more about protecting yourself from malicious actors, visit our package security documentation.