Wrapper around py2neo returning Futures, helping support multiple concurrent database queries
Note: This package has only been tested with py2neo version 3
Drop in replacement for py2neo.Graph: `python from py2neo import Graph ` becomes `python from lazy_py2neo import Graph `
After changing the import, calls that should return a Future can be modified like this: `python graph = Graph() result = graph.evaluate("MATCH (node) RETURN COUNT(node)") # result is a dict ` becomes `python graph = Graph() result = graph.evaluate("MATCH (node) RETURN COUNT(node)", as_future=True) # result is a Future evaluated_result = result.result() # evaluated_result is a dict `
Home-page: UNKNOWN Author: Bart Broere Author-email: UNKNOWN License: UNKNOWN Description: UNKNOWN Platform: UNKNOWN
Metadata
Release files for lazy-py2neo 2019.3.7
For a detailed explanation of source distributions (sdists) and built distributions (wheels), please see the package formats documentation.
Source distribution (sdist)
| File | Size | Uploaded | |
|---|---|---|---|
| lazy_py2neo-2019.3.7.tar.gz | 1.8 kB | Details |
Built distribution (wheel)
| File | Interpreter | ABI | Platform | Reset |
|---|---|---|---|---|
| lazy_py2neo-2019.3.7-py3-none-any.whl | Python 3 | none | any | Details |
Total release size: 4.8 kB
Release files / lazy_py2neo-2019.3.7.tar.gz
| Download URL | lazy_py2neo-2019.3.7.tar.gz |
|---|---|
| Size | 1.8 kB |
| Tags | Source |
|
SHA-256 checksum How to use checksums |
8d037a51418225ba0b5f6238e3ce3886af1979809427c41659b9ffe465d6425f
|
|
BLAKE2b-256 checksum How to use checksums |
3272886054174f1ba9ab5d3c3699768334b079206cc07e4468dbada03f361843
|
| Upload date | |
|
Uploaded using Trusted Publishing? What is trusted publishing? |
No |
| Uploaded via |
twine/1.11.0 pkginfo/1.4.2 requests/2.20.0 setuptools/40.5.0 requests-toolbelt/0.8.0 tqdm/4.25.0 CPython/3.6.7
|
Release files / lazy_py2neo-2019.3.7-py3-none-any.whl
| Download URL | lazy_py2neo-2019.3.7-py3-none-any.whl |
|---|---|
| Size | 3.1 kB |
| Tags | Python 3 |
|
SHA-256 checksum How to use checksums |
73840157acafac0690b0b58e4d56fde1381003a3459a9710545d0de876e4a746
|
|
BLAKE2b-256 checksum How to use checksums |
9a3395890f7f52429c02396ed5cb2f906afa5afc2cb77f0cb03dd14760bad941
|
| Upload date | |
|
Uploaded using Trusted Publishing? What is trusted publishing? |
No |
| Uploaded via |
twine/1.11.0 pkginfo/1.4.2 requests/2.20.0 setuptools/40.5.0 requests-toolbelt/0.8.0 tqdm/4.25.0 CPython/3.6.7
|