Skip to main content

A Python implementation of ElsieFour (LC4)

Project description

A Python library that implements ElsieFour (LC4) encryption, based on the algorithm in (Alan Kaminsky 2017).

Features

Requirements

LC4 supports Python 3.x.

Linux, Mac, and Windows are supported.

Other operating systems may be compatible if NumPy can be properly installed.

Installation

LC4 is available on PyPI, the Python Package Index.

$ pip3 install lc4

Documentation

See documentation.md.

Example Usage

See example.py.

License

The code in this repository has an MIT License.

See LICENSE.

References

Kaminsky, Alan. “ElsieFour: A Low-Tech Authenticated Encryption Algorithm For Human-to-Human Communication,” 2017. https://eprint.iacr.org/2017/339.

Project details


Download files

Download the file for your platform. If you're not sure which to choose, learn more about installing packages.

Source Distribution

lc4-0.2.2.tar.gz (7.5 kB view hashes)

Uploaded source

Supported by

AWS AWS Cloud computing Datadog Datadog Monitoring Facebook / Instagram Facebook / Instagram PSF Sponsor Fastly Fastly CDN Google Google Object Storage and Download Analytics Huawei Huawei PSF Sponsor Microsoft Microsoft PSF Sponsor NVIDIA NVIDIA PSF Sponsor Pingdom Pingdom Monitoring Salesforce Salesforce PSF Sponsor Sentry Sentry Error logging StatusPage StatusPage Status page