Skip to main content

Python bindings for LLVM

Project description

Versions

This package has been tested with LLVM 3.1, Python 2.7 and Python 3.2. Other Python versions should work, but some modifications may be needed for the upcoming LLVM 3.2

Quickstart

  1. Get 3.1 version of LLVM, build it. Make sure --enable-pic is passed to LLVM’s configure.

  2. Get llvm-py and install it:

    $ git clone git@github.com:llvmpy/llvmpy.git
    $ cd llvmpy
    $ python setup.py install
    

    Run the tests:

    $ python -c "import llvm; llvm.test()"
    
  3. See documentation at ‘http://www.llvmpy.org’ and examples under ‘test’.

LICENSE

llvmpy is distributed under the new BSD license, which is similar to the LLVM license itself. See the file called LICENSE for the full license text.

Project details


Download files

Download the file for your platform. If you're not sure which to choose, learn more about installing packages.

Files for llvmpy, version 0.9
Filename, size File type Python version Upload date Hashes
Filename, size llvmpy-0.9.tar.gz (414.0 kB) File type Source Python version None Upload date Hashes View

Supported by

Pingdom Pingdom Monitoring Google Google Object Storage and Download Analytics Sentry Sentry Error logging AWS AWS Cloud computing DataDog DataDog Monitoring Fastly Fastly CDN DigiCert DigiCert EV certificate StatusPage StatusPage Status page