Skip to main content
Help us improve Python packaging – donate today!

Node.js version manager

Project Description

nodevers is a Node.js version manager.

Prerequisites

To run nodevers you’ll need:

And to build Node.js you’ll need:

  • GNU make (3.81 or newer)
  • A C(++) compiler
  • Python (2.6 or 2.7)
  • libssl-dev (only if you want to build Node v0.6.x)
  • libexecinfo (only if you are using FreeBSD or OpenBSD)

Installation

To install nodevers, simply run:

$ pip install nodevers

Or if you have downloaded a zip/cloned from GitHub:

$ python setup.py install

You’ll also need to add either:

  • ~/.nodevers/bin

or

  • $NODEVERS_PREFIX/bin if you have set the environment variable NODEVERS_PREFIX

or

  • /opt/nodevers/bin if you run nodevers and install Nodes as root

to the PATH.

Usage

Installing a Node:

$ nodevers install 0.10.17

Switching to a Node:

$ nodevers use 0.10.17

You can also pass arguments to Node’s configure script during building:

$ nodevers install 0.10.17 --buildargs="--gdb"

License

nodevers is licensed under BSD (3-Clause) License. See the LICENSE file for the full license text.

Release history Release notifications

This version
History Node

0.2.1

History Node

0.2.0

History Node

0.1.1

History Node

0.1.0

Download files

Download the file for your platform. If you're not sure which to choose, learn more about installing packages.

Filename, size & hash SHA256 hash help File type Python version Upload date
nodevers-0.2.1.tar.gz (8.3 kB) Copy SHA256 hash SHA256 Source None Sep 10, 2013

Supported by

Elastic Elastic Search Pingdom Pingdom Monitoring Google Google BigQuery Sentry Sentry Error logging CloudAMQP CloudAMQP RabbitMQ AWS AWS Cloud computing Fastly Fastly CDN DigiCert DigiCert EV certificate StatusPage StatusPage Status page