Skip to main content

Runs Neural Networks for usage in the KM3NeT project

Project description

https://badge.fury.io/py/orcanet.svg https://git.km3net.de/ml/OrcaNet/badges/master/pipeline.svg https://examples.pages.km3net.de/km3badges/docs-latest-brightgreen.svg https://git.km3net.de/ml/OrcaNet/badges/master/coverage.svg Codacy Badge

OrcaNet is a deep learning framework based on tensorflow in order to simplify the training process of neural networks for astroparticle physics. It incorporates automated logging, plotting and validating during the training, as well as saving and continuing the training process. Additionally, it features easy management of multiple neural network inputs and the use of training data which is split over multiple files.

In this sense, it tackles many challenges that are usually found in astroparticle physics, like huge datasets.

OrcaNet is a part of the Deep Learning efforts for the neutrino telescope KM3NeT. Find more information about KM3NeT on http://www.km3net.org

OrcaNet is currently being developed at the official KM3NeT gitlab (https://git.km3net.de/ml/OrcaNet).

However, there’s also a github mirror that can be found at https://github.com/ViaFerrata/OrcaNet.

OrcaNet can be installed via pip by running:

pip install orcanet

In order to make use of tensorflow’s GPU acceleration, you need cuda and cudnn installed. You can see which of these each tensorflow version needs here https://www.tensorflow.org/install/source#gpu

Containerization

A Singularity image of the latest stable version of OrcaNet with tf and cuda/cudnn is automatically uploaded to our sftp server. Download it via wget http://pi1139.physik.uni-erlangen.de/singularity/orcanet.sif and run it e.g. via singularity shell orcanet.sif

Tensorflow 1.X

Orcanet per default runs on tensorflow 2, but there is also a no longer supperted tf 1 branch tf1, which makes use of the deprecated stand-alone keras package. For the tf 1 version, orcanet will install tensorflow (the cpu version). For training with graphics cards, tensorflow-gpu is required, which needs to be installed manually via:

pip install tensorflow-gpu

Project details


Download files

Download the file for your platform. If you're not sure which to choose, learn more about installing packages.

Files for orcanet, version 0.12.1
Filename, size File type Python version Upload date Hashes
Filename, size orcanet-0.12.1.tar.gz (1.5 MB) File type Source Python version None Upload date Hashes View

Supported by

AWS AWS Cloud computing Datadog Datadog Monitoring DigiCert DigiCert EV certificate Facebook / Instagram Facebook / Instagram PSF Sponsor Fastly Fastly CDN Google Google Object Storage and Download Analytics Pingdom Pingdom Monitoring Salesforce Salesforce PSF Sponsor Sentry Sentry Error logging StatusPage StatusPage Status page