Skip to main content

Poetry plugin used to tweak dependency versions

Project description

Poetry plugin tweak dependencies version

Plugin use to tweak the dependencies of the project.

Will be used when we have different constraints for the dependencies, like publish and dependency upgrader like Renovate.

This plugin will let us tweak the dependencies of the published packages.

Config:

[build-system]
requires = ["poetry-core>=1.0.0", "poetry-plugin-tweak-dependencies-version"]
build-backend = "poetry.core.masonry.api"

[tool.poetry-plugin-tweak-dependencies-version]
default = "(present|major|minor|patch|full)" # Default to `full`
"<package>" = "(present|major|minor|patch|full)"

present => *, major => x.*, minor => x.y.*, patch => x.y.z, full => keep the original version.

Project details


Download files

Download the file for your platform. If you're not sure which to choose, learn more about installing packages.

Source Distributions

No source distribution files available for this release. See tutorial on generating distribution archives.

Built Distribution

Supported by

AWS AWS Cloud computing Datadog Datadog Monitoring Facebook / Instagram Facebook / Instagram PSF Sponsor Fastly Fastly CDN Google Google Object Storage and Download Analytics Huawei Huawei PSF Sponsor Microsoft Microsoft PSF Sponsor NVIDIA NVIDIA PSF Sponsor Pingdom Pingdom Monitoring Salesforce Salesforce PSF Sponsor Sentry Sentry Error logging StatusPage StatusPage Status page