Skip to main content

Adds python support to pyqode.core

Project description

https://raw.githubusercontent.com/pyQode/pyQode/master/media/pyqode-banner.png

Latest PyPI version Number of PyPI downloads https://img.shields.io/pypi/l/pyqode.python.svg Travis-CI build status Coverage Status

About

pyqode.python adds python support to pyQode (code completion, calltips, …).

Features:

  • calltips mode (using Jedi)
  • code completion provider (using Jedi)
  • code folding mode
  • auto indent mode
  • on the fly code checkers (frosted (fork of PyFlakes), PEP8)
  • a customisable python specific syntax highlighter
  • a pre-configured QPythonCodeEdit (with the corresponding Qt Designer plugin)

License

pyQode is licensed under the MIT license.

Requirements

pyqode.python depends on the following libraries:

  • python 2.7 or python 3 (>= 3.2)
  • pyqode.core
  • jedi
  • pep8
  • frosted
  • docutils

Installation

$ pip install pyqode.python --upgrade

Testing

pyqode.core has a test suite and measure its coverage.

To run the tests, just run runtests.py with the interpreter you want to run the test suite:

python2.7 runtests.py
python3.4 runtests.py

To measure coverage, install pytest-cov package and run:

python runtests.py --cov pyqode

To check for PEP8 warnings, use:

python runtests.py –pep8 -m pep8

Project details


Download files

Download the file for your platform. If you're not sure which to choose, learn more about installing packages.

Filename, size & hash SHA256 hash help File type Python version Upload date
pyqode.python-2.7.0-py2.py3-none-any.whl (46.6 kB) Copy SHA256 hash SHA256 Wheel py2.py3
pyqode.python-2.7.0.tar.gz (435.8 kB) Copy SHA256 hash SHA256 Source None

Supported by

Elastic Elastic Search Pingdom Pingdom Monitoring Google Google BigQuery Sentry Sentry Error logging AWS AWS Cloud computing DataDog DataDog Monitoring Fastly Fastly CDN SignalFx SignalFx Supporter DigiCert DigiCert EV certificate StatusPage StatusPage Status page