Skip to main content

zc.buildout recipe for installing ruby gems.

Project description

*******************************
Recipe for installing ruby gems
*******************************

Using this recipe you can easily install ruby gems packages into buildout
environment.

All executable files from gem packages are available in ``bin-directory``.

Usage
=====

::

[buildout]
parts =
rubygems

[rubygems]
recipe = rubygemsrecipe
gems =
sass
compass==0.10

After running buildout you can use SASS from buildout environment::

./bin/sass --version

Options
=======

gems
list of gem package names, also you can specify gem version, example:
``sass==3.1.1``.

url
rubygems zip download url, if not specified, recipe will try to find most
recent version.

version
rubygems version, if not specified, recipe will try to find most recent
version.

ruby-executable
A path to a Ruby executable. Gems will be installed using this executable.

gem-options
Extra options, that will be passed to gem executable. Example::

gem-options =
--with-icu-lib=${icu:location}/lib/
--with-icu-dir=${icu:location}/

environment
Possibility to add or override environment variables. Example::

environment =
LDFLAGS = -L${icu:location}/lib -Wl,-rpath=${icu:location}/lib
CFLAGS = -I${icu:location}/include

Change History
**************

0.2.0 (2014-11-20)
==================

- Native Python 2 and Python 3 support using ``six``, without ``use_2to3``.

- Tests for Python 2 and Python 3 using ``tox`` with 100% test coverage.

- All ``subprocess`` commands are rewritten to run without ``shell=True``.

0.1.8 (2014-01-26)
==================

- Feature: Python 3 support.

- Feature: added 'url', 'gem-options' and 'environment' options.

- Fix: add quotes to values of environment variables.

0.1.7 (2012-05-24)
==================

- Feature: added 'ruby-executable' option, thanks to desaintmartin.

0.1.6 (2012-04-26)
==================

- Fix: pass all arguments as separate arguments instead of a single string.

0.1.5 (2012-01-06)
==================

- Fix: use each version only for the line it's specified in.

0.1.4 (2012-01-03)
==================

- You can specify a version for each gem with a syntax similar to python eggs.


0.1.3 (2011-12-28)
==================

- Added 'version' option to specify explicit rubygems version.

0.1.2 (2011-11-09)
==================

- New version of rubygems includes symlinks in .tgz archyve and extracted by
setuptools.archive_util extractor ignores all symlinks. This causes missing
files in extracted folder. Now rubygemsrecipe downloads .zip archyve instead
of .tgz.

0.1.1 (2011-10-04)
==================

- Fixed issue with name of gem executable, which can be different depending on
how ruby is istalled on host system.

- Install rubygems if gem executable is not found, not rubygems direcotry.

0.1 (2011-09-07)
================

- Initial public release.

Project details


Download files

Download the file for your platform. If you're not sure which to choose, learn more about installing packages.

Files for rubygemsrecipe, version 0.2.0
Filename, size File type Python version Upload date Hashes
Filename, size rubygemsrecipe-0.2.0-py2-none-any.whl (7.4 kB) File type Wheel Python version py2 Upload date Hashes View hashes
Filename, size rubygemsrecipe-0.2.0-py3-none-any.whl (7.4 kB) File type Wheel Python version py3 Upload date Hashes View hashes
Filename, size rubygemsrecipe-0.2.0.tar.gz (5.2 kB) File type Source Python version None Upload date Hashes View hashes

Supported by

Elastic Elastic Search Pingdom Pingdom Monitoring Google Google BigQuery Sentry Sentry Error logging AWS AWS Cloud computing DataDog DataDog Monitoring Fastly Fastly CDN SignalFx SignalFx Supporter DigiCert DigiCert EV certificate StatusPage StatusPage Status page