Skip to main content
Help us improve PyPI by participating in user testing. All experience levels needed!

Zope application server ZCML files

Project description

Change History

4.0.0 (2017-05-29)

  • Add support for Python 3.4, 3.5, 3.6 and PyPy. Update minimum dependency versions appropriately.

3.8.0 (2013-08-27)

  • Remove include of zope.app.zopeappgenerations that is not useful unless upgrading a database older than Zope 3.4. This cuts the last dependency on zope.app.authentication from the ZTK.

3.7.1 (2011-07-26)

  • Move include of zope.dublincore.browser here from zope.dublincore (LP: #590668).

3.7.0 (2009-12-28)

  • Use new zope.app.locales which has its own configure.zcml.
  • No longer using zope.testing.doctestunit as it is deprecated now. Using python’s doctest module.

3.6.1 (2009-12-16)

  • Removed reference to no longer existing configure.zcml from zope.app.pagetemplate.tests.

3.6.0 (2009-07-11)

  • No longer depends on deprecated zope.app.interface but on zope.componentvocabulary.

3.5.5 (2009-05-23)

  • Added missing dependencies, including zope.app.http and zope.app.applicationcontrol.

3.5.4 (2009-05-18)

  • Added missing zope.app.exception dependency, as we include its ZCML.
  • Added missing zope.app.testing test dependency to make tests pass.

3.5.3 (2009-02-04)

  • Added zope.app.broken dependency (we include its ZCML).

3.5.2 (2009-01-31)

  • We depended on zope.formlib but didn’t include its configuration. Now it’s included in configure.zcml.
  • We include ZCML of zope.app.error but didn’t mention it as a dependency.

3.5.1 (2008-12-28)

  • Add include of zope.app.schema:configure.zcml. Because component-based vocabularies are used everywhere and we need to import zope.app.schema somehow to make it work. This is needed because of removal of the include of zope.app.schema’s meta.zcml in the previous release.

3.5.0 (2008-12-16)

  • Remove deprecated include of zope.app.component.browser:meta.zcml.
  • Remove deprecated include of zope.app.schema:meta.zcml.
  • Remove use of zope.modulealias.

3.4.3 (2007-11-01)

  • Fix test failure due to missing zope.app.container.browser.ftests
    directory. Now it is moved to zope.app.container.browser.tests.

3.4.2 (2007-10-30)

  • Fix test failure due to missing zope.app.form.browser.ftests directory. Now it is moved to zope.app.form.browser.tests.

3.4.1 (2007-10-23)

  • Added missing dependency.

3.4.0 (2007-10-03)

  • Initial public release as an individual package.

Release history Release notifications

This version
History Node

4.0.0

History Node

3.8.0

History Node

3.7.1

History Node

3.7.0

History Node

3.6.1

History Node

3.6.0

History Node

3.5.5

History Node

3.5.4

History Node

3.5.3

History Node

3.5.2

History Node

3.5.1

History Node

3.5.0

History Node

3.4.3

History Node

3.4.2

History Node

3.4.1

History Node

3.4.0

History Node

3.4.0a1

Download files

Download the file for your platform. If you're not sure which to choose, learn more about installing packages.

Filename, size & hash SHA256 hash help File type Python version Upload date
zope.app.zcmlfiles-4.0.0-py2-none-any.whl (9.2 kB) Copy SHA256 hash SHA256 Wheel py2 May 29, 2017
zope.app.zcmlfiles-4.0.0-py2.py3-none-any.whl (9.2 kB) Copy SHA256 hash SHA256 Wheel py2.py3 May 29, 2017
zope.app.zcmlfiles-4.0.0.tar.gz (9.4 kB) Copy SHA256 hash SHA256 Source None May 29, 2017

Supported by

Elastic Elastic Search Pingdom Pingdom Monitoring Google Google BigQuery Sentry Sentry Error logging CloudAMQP CloudAMQP RabbitMQ AWS AWS Cloud computing Fastly Fastly CDN DigiCert DigiCert EV certificate StatusPage StatusPage Status page