Skip to main content

The ultimate Python library in building OAuth and OpenID Connect servers. JWS, JWK, JWA, JWT are included.

Specifications

  • RFC5849: The OAuth 1.0 Protocol

  • RFC6749: The OAuth 2.0 Authorization Framework

  • RFC6750: The OAuth 2.0 Authorization Framework: Bearer Token Usage

  • RFC7009: OAuth 2.0 Token Revocation

  • RFC7515: JSON Web Signature

  • RFC7516: JSON Web Encryption

  • RFC7517: JSON Web Key

  • RFC7518: JSON Web Algorithms

  • RFC7519: JSON Web Token

  • RFC7521: Assertion Framework for OAuth 2.0 Client Authentication and Authorization Grants

  • RFC7523: JSON Web Token (JWT) Profile for OAuth 2.0 Client Authentication and Authorization Grants

  • RFC7591: OAuth 2.0 Dynamic Client Registration Protocol

  • RFC7636: Proof Key for Code Exchange by OAuth Public Clients

  • RFC7638: JSON Web Key (JWK) Thumbprint

  • RFC7662: OAuth 2.0 Token Introspection

  • RFC8037: CFRG Elliptic Curve Diffie-Hellman (ECDH) and Signatures in JSON Object Signing and Encryption (JOSE)

  • RFC8414: OAuth 2.0 Authorization Server Metadata

  • RFC8628: OAuth 2.0 Device Authorization Grant

  • OpenID Connect 1.0

  • OpenID Connect Discovery 1.0

  • draft-madden-jose-ecdh-1pu-04: Public Key Authenticated Encryption for JOSE: ECDH-1PU

Implementations

  • Requests OAuth 1 Session

  • Requests OAuth 2 Session

  • Requests Assertion Session

  • HTTPX OAuth 1 Session

  • HTTPX OAuth 2 Session

  • HTTPX Assertion Session

  • Flask OAuth 1/2 Client

  • Django OAuth 1/2 Client

  • Starlette OAuth 1/2 Client

  • Flask OAuth 1.0 Server

  • Flask OAuth 2.0 Server

  • Flask OpenID Connect 1.0

  • Django OAuth 1.0 Server

  • Django OAuth 2.0 Server

  • Django OpenID Connect 1.0

License

Authlib is licensed under BSD. Please see LICENSE for licensing details.

If this license does not fit your company, consider to purchase a commercial license. Find more information on Authlib Plans.

Metadata

Release files for Authlib 1.0.0

For a detailed explanation of source distributions (sdists) and built distributions (wheels), please see the package formats documentation.

Source distribution (sdist)

Source distribution for Authlib 1.0.0
File Size Uploaded
Authlib-1.0.0.tar.gz 140.0 kB Details

Built distribution (wheel)

Table of built distributions (wheels) for Authlib 1.0.0
File Interpreter ABI Platform
Authlib-1.0.0-py2.py3-none-any.whl Python 2, Python 3 none any Details

Total release size: 354.1 kB

Release files / Authlib-1.0.0.tar.gz

Download URL Authlib-1.0.0.tar.gz
Size 140.0 kB
Tags Source
SHA-256 checksum
How to use checksums
2b13b4ba6465bdc46b89b1a07b2707c85b3434502d5a5fe202f5bdef8ebd5ac9
BLAKE2b-256 checksum
How to use checksums
006a4b63f80997d03aa486ecbb86fe4b6bc925c423d7b325787a1f89e9ace842
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
No
Uploaded via twine/3.4.2 importlib_metadata/4.8.1 pkginfo/1.7.1 requests/2.25.0 requests-toolbelt/0.9.1 tqdm/4.62.3 CPython/3.8.10

Release files / Authlib-1.0.0-py2.py3-none-any.whl

Download URL Authlib-1.0.0-py2.py3-none-any.whl
Size 214.1 kB
Tags Python 2 Python 3
SHA-256 checksum
How to use checksums
e8d589a886b5bcde64ebf961157bf619d613666ef6703822c06254c5b108b3e6
BLAKE2b-256 checksum
How to use checksums
a8a0aa2bfc6ee6587a5c1beefdb3cc530d627fa6c0c9c2ba575b8e39dcdb2d46
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
No
Uploaded via twine/3.4.2 importlib_metadata/4.8.1 pkginfo/1.7.1 requests/2.25.0 requests-toolbelt/0.9.1 tqdm/4.62.3 CPython/3.8.10

Release history Release notifications | RSS feed

1.8.0

2 release files

1.7.2

2 release files

1.7.1

2 release files

1.7.0

2 release files

1.6.11

2 release files

1.6.10

2 release files

1.6.9

2 release files

1.6.8

2 release files

1.6.7

2 release files

1.6.6

2 release files

1.6.5

2 release files

1.6.4

2 release files

1.6.3

2 release files

1.6.2

2 release files

1.6.1

2 release files

1.6.0

2 release files

1.5.2

2 release files

1.5.1

2 release files

1.5.0

2 release files

1.4.1

2 release files

1.4.0

2 release files

1.3.2

2 release files

1.3.1

2 release files

1.3.0

2 release files

1.2.1

2 release files

1.2.0

2 release files

1.1.0

2 release files

1.0.1

2 release files

This release

1.0.0 This release

2 release files

0.15.5

2 release files

0.15.3

2 release files

0.15.2

2 release files

0.15.1

2 release files

0.15

2 release files

0.14.3

2 release files

0.14.1

2 release files

0.14

2 release files

0.13

2 release files

0.12.1

2 release files

0.12

2 release files

0.11

2 release files

0.10

2 release files

0.9

2 release files

0.8

2 release files

0.7

2 release files

0.6

2 release files

0.5.1

2 release files

0.5

2 release files

0.4.1

2 release files

0.4

2 release files

0.3

2 release files

0.2.1

2 release files

0.2

2 release files

0.1

1 release file

0.1rc0

Anthropic, PBC Visionary sponsor Bloomberg Visionary sponsor Hudson River Trading Visionary sponsor Meta Visionary sponsor NVIDIA Visionary sponsor Microsoft Sustainability sponsor Depot Continuous Integration AWS Cloud computing and Security Sponsor Datadog Monitoring Fastly CDN Google Download Analytics Sentry Error logging StatusPage Status page