# Agensgraph python driver
A psycopg2 extension to use [AgensGraph][1] with Python.
### Documentation
Go to [Psycopg's documentation][2] for documentation about the Python interface and to [AgensGraph][1] documentation for AgensSQL. If you want to learn more about Cypher, I recommend you to go to [Neo4j's][3] documentation.
### How to
```python
import agensgraph
conn = agensgraph.connect("dbname=iomed") # Equivalent to psycopg2.connect
cur = conn.cursor()
cur.execute("SET graph_path=snomed;")
cur.execute("MATCH (a)-[r]->(b) RETURN a,r,b LIMIT 10;")
result = cur.fetchall()
```
**Copyright © 2017, IOMED Medical Solutions S.L.**
[1]: http://bitnine.net/wp-content/uploads/2017/06/html5/main.html
[2]: http://initd.org/psycopg/docs/index.html
[3]: https://neo4j.com/docs/developer-manual/current/cypher/
A psycopg2 extension to use [AgensGraph][1] with Python.
### Documentation
Go to [Psycopg's documentation][2] for documentation about the Python interface and to [AgensGraph][1] documentation for AgensSQL. If you want to learn more about Cypher, I recommend you to go to [Neo4j's][3] documentation.
### How to
```python
import agensgraph
conn = agensgraph.connect("dbname=iomed") # Equivalent to psycopg2.connect
cur = conn.cursor()
cur.execute("SET graph_path=snomed;")
cur.execute("MATCH (a)-[r]->(b) RETURN a,r,b LIMIT 10;")
result = cur.fetchall()
```
**Copyright © 2017, IOMED Medical Solutions S.L.**
[1]: http://bitnine.net/wp-content/uploads/2017/06/html5/main.html
[2]: http://initd.org/psycopg/docs/index.html
[3]: https://neo4j.com/docs/developer-manual/current/cypher/
Metadata
Release files for agensgraph 0.0.2
For a detailed explanation of source distributions (sdists) and built distributions (wheels), please see the package formats documentation.
Source distribution (sdist)
| File | Size | Uploaded | Provenance | |
|---|---|---|---|---|
| agensgraph-0.0.2.tar.gz | 2.9 kB | Without provenance | Details |
Release files / agensgraph-0.0.2.tar.gz
| Download URL | agensgraph-0.0.2.tar.gz |
|---|---|
| Size | 2.9 kB |
| Tags | Source |
|
SHA-256 checksum How to use checksums |
e7d3af5c09541b3fd7e7f40a44104eb71ccb3ec5e6ea30005b43231ac06479cd
|
|
BLAKE2b-256 checksum How to use checksums |
aaaaa4cfe3373e6cb615fa8a31ac8cf18d13ee46166e78c835b4ddb6d718c497
|
| Upload date | |
|
Uploaded using Trusted Publishing? What is trusted publishing? |
No |
Security for agensgraph 0.0.2
Provenance
Provenance describes where a file came from. On PyPI, provenance is shared via attestations, which provide a verifiable record of the build or publishing details. View details, limitations and caveats.
No provenance found
None of the files in this release were uploaded with provenance metadata.
A note on package security
PyPI is a repository for distributing packages, not a service for auditing them. While third-party security researchers and our staff do their best to detect and remove malicious packages, PyPI cannot guarantee the quality, security or suitability of any given package.