Skip to main content

A Rollbar support plugin for Django Q

Project description

django-q-rollbar

A Django Q Error Reporter plugin adding Rollbar support.

Installation

This plugin is intended to be included with Django Q as setuptools extra.

$ pip install django-q[rollbar]

Or add django-q[rollbar] to requirements.txt.

This plugin requires Django Q version 0.8.1 or greater. Earlier versions of Django Q can incorporate rollbar support via the rollbar key in the Q_CLUSTER settings dictionary.

Usage

Configure Rollbar via the Django Q Q_CLUSTER dictionary in your Django project's settings.py. It is important that the rollbar key be set in the error_reporter dictionary, as this name aligns with the project's entry point for this plugin.

Q_CLUSTER = {
    'error_reporter': {
        'rollbar': {
            'access_token': '32we33a92a5224jiww8982',
            'environment': 'Django-Q'
        }
    }
}

Please check the Pyrollbar configuration reference for more options. Additional options defined in Q_CLUSTER are passed directly as kwargs to Pyrollbar's rollbar.init.

Of course, you will need a Rollbar account and access token to use this plugin.

Project details


Download files

Download the file for your platform. If you're not sure which to choose, learn more about installing packages.

Files for django-q-rollbar, version 0.1.3
Filename, size File type Python version Upload date Hashes
Filename, size django-q-rollbar-0.1.3.tar.gz (2.2 kB) File type Source Python version None Upload date Hashes View

Supported by

Pingdom Pingdom Monitoring Google Google Object Storage and Download Analytics Sentry Sentry Error logging AWS AWS Cloud computing DataDog DataDog Monitoring Fastly Fastly CDN DigiCert DigiCert EV certificate StatusPage StatusPage Status page