Skip to main content

gs.dmarc

Look up and report on the DMARC status of a domain

Author:

Michael JasonSmith

Contact:

Michael JasonSmith <mpj17@onlinegroups.net>

Date:

2015-06-25

Organization:

GroupServer.org

Copyright:

This document is licensed under a Creative Commons Attribution-Share Alike 4.0 International License by OnlineGroups.net.

Introduction

This product allows systems look up and report on the DMARC (RFC 7489: Domain-based Message Authentication, Reporting and Conformance) status of a domain. DMARC allows the owner of a domain to publish a key that is used to verify if an email message actually originated from the domain, and to publish what to do if the verification fails. It is an extension of DKIM (RFC 6376: DomainKeys Identified Mail) and SPF (RFC 4408: Sender Policy Framework).

Specifically this product supplies gs.dmarc.ReceiverPolicy for enumerating [1] the different DMARC policies, and the receiver_policy function for querying the policy for a given domain.

Resources

Metadata

Release files for gs.dmarc 2.1.9

For a detailed explanation of source distributions (sdists) and built distributions (wheels), please see the package formats documentation.

Source distribution (sdist)

Source distribution for gs.dmarc 2.1.9
File Size Uploaded Provenance Actions
gs.dmarc-2.1.9.zip 579.6 kB Without provenance Details for gs.dmarc-2.1.9.zip

Built distribution (wheel)

Table of built distributions (wheels) for gs.dmarc 2.1.9
File Interpreter ABI Platform Actions
gs.dmarc-2.1.9-py2.py3-none-any.whl Python 3, Python 2 none any Details for gs.dmarc-2.1.9-py2.py3-none-any.whl

Total release size: 656.1 kB

Release files / gs.dmarc-2.1.9.zip

Download URL gs.dmarc-2.1.9.zip
Size 579.6 kB
Tags Source
SHA-256 checksum
How to use checksums
e97e1e6e73dc39d9f1699f751a34b46f4a0aabddeb7a5837fbefe785634d48e4
BLAKE2b-256 checksum
How to use checksums
2d94340cb711ab9226c5d7652311945ada26b96bf98ea2edcac71533fb4190a7
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
No

Release files / gs.dmarc-2.1.9-py2.py3-none-any.whl

Download URL gs.dmarc-2.1.9-py2.py3-none-any.whl
Size 76.5 kB
Tags Python 2 Python 3
SHA-256 checksum
How to use checksums
0d09fd2d9098690ab05b80103df51334de67d4af085e3e7819171a2ed7778b3d
BLAKE2b-256 checksum
How to use checksums
1b2248f57d34dab76b981005e7a6fa9df8494377f8c741f0748b2b35ca6e2d3a
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
No

Security for gs.dmarc 2.1.9

Provenance

Provenance describes where a file came from. On PyPI, provenance is shared via attestations, which provide a verifiable record of the build or publishing details. View details, limitations and caveats.

No provenance found

None of the files in this release were uploaded with provenance metadata.

A note on package security

PyPI is a repository for distributing packages, not a service for auditing them. While third-party security researchers and our staff do their best to detect and remove malicious packages, PyPI cannot guarantee the quality, security or suitability of any given package.

To learn more about protecting yourself from malicious actors, visit our package security documentation.

Anthropic, PBC Visionary sponsor Bloomberg Visionary sponsor Hudson River Trading Visionary sponsor Meta Visionary sponsor NVIDIA Visionary sponsor Microsoft Sustainability sponsor Depot Continuous Integration AWS Cloud computing and Security Sponsor Datadog Monitoring Fastly CDN Google Download Analytics Sentry Error logging StatusPage Status page