Skip to main content
https://badge.fury.io/gh/pythongssapi%2Fpython-gssapi.svg https://badge.fury.io/py/gssapi.svg

Python-GSSAPI provides both low-level and high level wrappers around the GSSAPI C libraries. While it focuses on the Kerberos mechanism, it should also be useable with other GSSAPI mechanisms.

Documentation can be found at https://pythongssapi.github.io/python-gssapi/.

Requirements

Basic

  • A working implementation of GSSAPI (such as from MIT Kerberos) which supports delegation and includes header files

  • a C compiler (such as GCC)

  • Python 3.7+ (older releases support older versions, but are unsupported)

  • the decorator python package

Compiling from Scratch

To compile from scratch, you will need Cython >= 0.29.29 which is automatically installed by pip in an isolated build virtual environment.

For Running the Tests

  • the k5test package

To install test dependencies using pip:

$ pip install -r test-requirements.txt # Optional, for running test suite

Installation

Easy Way

$ pip install gssapi

From the Git Repo

After being sure to install all the requirements,

$ git clone https://github.com/pythongssapi/python-gssapi.git
$ pip install .

Tests

The tests for for Python-GSSAPI live in gssapi.tests. In order to run the tests, you must have an MIT Kerberos installation (including the KDC). The tests create a self-contained Kerberos setup, so running the tests will not interfere with any existing Kerberos installations.

Structure

Python-GSSAPI is composed of two parts: a low-level C-style API which thinly wraps the underlying RFC 2744 methods, and a high-level, Pythonic API (which is itself a wrapper around the low-level API). Examples may be found in the examples directory.

Low-Level API

The low-level API lives in gssapi.raw. The methods contained therein are designed to match closely with the original GSSAPI C methods. All relevant methods and classes may be imported directly from gssapi.raw. Extension methods will only be imported if they are present. The low-level API follows the given format:

  • Names match the RFC 2744 specification, with the gssapi_ prefix removed

  • Parameters which use C int constants as enums have enum.IntEnum classes defined, and thus may be passed either the enum members or integers

  • In cases where a specific constant is passed in the C API to represent a default value, None should be passed instead

  • In cases where non-integer constants would be used in the API (i.e. OIDs), enum-like objects have been defined containing named references to values specified in RFC 2744.

  • Major and minor error codes are returned by raising gssapi.raw.GSSError. The major error codes have exceptions defined in in gssapi.raw.exceptions to make it easier to catch specific errors or categories of errors.

  • All other relevant output values are returned via named tuples.

High-Level API

The high-level API lives directly under gssapi. The classes contained in each file are designed to provide a more Pythonic, Object-Oriented view of GSSAPI. The exceptions from the low-level API, plus several additional exceptions, live in gssapi.exceptions. The rest of the classes may be imported directly from gssapi. Only classes are exported by gssapi – all functions are methods of classes in the high-level API.

Please note that QoP is not supported in the high-level API, since it has been deprecated.

Extensions

In addition to RFC 2743/2744, Python-GSSAPI also has support for:

  • RFC 4178 (GSS-API Negotiation Mechanism)

  • RFC 5587 (Extended GSS Mechanism Inquiry APIs)

  • RFC 5588 (GSS-API Extension for Storing Delegated Credentials)

  • RFC 5801 (GSS-API SASL Extensions)

  • (Additional) Credential Store Extension

  • Services4User

  • Credentials import-export

  • RFC 6680 (GSS-API Naming Extensions)

  • DCE and IOV MIC extensions

  • acquire_cred_with_password and add_cred_with_password

  • GGF Extensions

  • Kerberos specific extensions

The Team

(GitHub usernames in parentheses)

  • Jordan Borean (@jborean93) - current maintainer and developer

  • Simo Sorce (@simo5) - developer

  • Robbie Harwood (@frozencemetery) - author emeritus

  • Solly Ross (@directxman12) - author emeritus

  • Hugh Cole-Baker (@sigmaris) - author emeritus

Get Involved

We welcome new contributions in the form of Issues and Pull Requests on Github. If you would like to join our discussions, you can find us on libera.chat IRC, channel #python-gssapi.

Metadata

Release files for gssapi 1.8.3

For a detailed explanation of source distributions (sdists) and built distributions (wheels), please see the package formats documentation.

Source distribution (sdist)

Source distribution for gssapi 1.8.3
File Size Uploaded
gssapi-1.8.3.tar.gz 94.2 kB Details

Built distributions (wheels)

Table of built distributions (wheels) for gssapi 1.8.3
File
gssapi-1.8.3-cp312-cp312-win_amd64.whl CPython 3.12 CPython 3.12 Windows x86-64 Details
gssapi-1.8.3-cp312-cp312-win32.whl CPython 3.12 CPython 3.12 Windows x86-32 Details
gssapi-1.8.3-cp312-cp312-macosx_11_0_arm64.whl CPython 3.12 CPython 3.12 macOS 11.0+ ARM64 Details
gssapi-1.8.3-cp312-cp312-macosx_10_9_x86_64.whl CPython 3.12 CPython 3.12 macOS 10.9+ x86-64 Details
gssapi-1.8.3-cp311-cp311-win_amd64.whl CPython 3.11 CPython 3.11 Windows x86-64 Details
gssapi-1.8.3-cp311-cp311-win32.whl CPython 3.11 CPython 3.11 Windows x86-32 Details
gssapi-1.8.3-cp311-cp311-macosx_11_0_arm64.whl CPython 3.11 CPython 3.11 macOS 11.0+ ARM64 Details
gssapi-1.8.3-cp311-cp311-macosx_10_9_x86_64.whl CPython 3.11 CPython 3.11 macOS 10.9+ x86-64 Details
gssapi-1.8.3-cp310-cp310-win_amd64.whl CPython 3.10 CPython 3.10 Windows x86-64 Details
gssapi-1.8.3-cp310-cp310-win32.whl CPython 3.10 CPython 3.10 Windows x86-32 Details
gssapi-1.8.3-cp310-cp310-macosx_11_0_arm64.whl CPython 3.10 CPython 3.10 macOS 11.0+ ARM64 Details
gssapi-1.8.3-cp310-cp310-macosx_10_9_x86_64.whl CPython 3.10 CPython 3.10 macOS 10.9+ x86-64 Details
gssapi-1.8.3-cp39-cp39-win_amd64.whl CPython 3.9 CPython 3.9 Windows x86-64 Details
gssapi-1.8.3-cp39-cp39-win32.whl CPython 3.9 CPython 3.9 Windows x86-32 Details
gssapi-1.8.3-cp39-cp39-macosx_11_0_arm64.whl CPython 3.9 CPython 3.9 macOS 11.0+ ARM64 Details
gssapi-1.8.3-cp39-cp39-macosx_10_9_x86_64.whl CPython 3.9 CPython 3.9 macOS 10.9+ x86-64 Details
gssapi-1.8.3-cp38-cp38-win_amd64.whl CPython 3.8 CPython 3.8 Windows x86-64 Details
gssapi-1.8.3-cp38-cp38-win32.whl CPython 3.8 CPython 3.8 Windows x86-32 Details
gssapi-1.8.3-cp38-cp38-macosx_11_0_arm64.whl CPython 3.8 CPython 3.8 macOS 11.0+ ARM64 Details
gssapi-1.8.3-cp38-cp38-macosx_10_9_x86_64.whl CPython 3.8 CPython 3.8 macOS 10.9+ x86-64 Details
gssapi-1.8.3-cp37-cp37m-win_amd64.whl CPython 3.7 CPython 3.7 pymalloc Windows x86-64 Details
gssapi-1.8.3-cp37-cp37m-win32.whl CPython 3.7 CPython 3.7 pymalloc Windows x86-32 Details
gssapi-1.8.3-cp37-cp37m-macosx_10_9_x86_64.whl CPython 3.7 CPython 3.7 pymalloc macOS 10.9+ x86-64 Details

Total release size: 17.7 MB

Release files / gssapi-1.8.3.tar.gz

Download URL gssapi-1.8.3.tar.gz
Size 94.2 kB
Tags Source
SHA-256 checksum
How to use checksums
aa3c8d0b1526f52559552bb2c9d2d6be013d76a8e5db00b39a1db5727e93b0b0
BLAKE2b-256 checksum
How to use checksums
13e7dd88180cfcf243be62308707cc2f5dae4c726c68f30b9367931c794fda16
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
Yes
Uploaded via twine/4.0.2 CPython/3.11.5

Release files / gssapi-1.8.3-cp312-cp312-win_amd64.whl

Download URL gssapi-1.8.3-cp312-cp312-win_amd64.whl
Size 866.6 kB
Tags CPython 3.12 Windows x86-64
SHA-256 checksum
How to use checksums
5731c5b40ecc3116cfe7fb7e1d1e128583ec8b3df1e68bf8cd12073160793acd
BLAKE2b-256 checksum
How to use checksums
21be6dc4dba46049e9b8a78a6022c8b9b8acdce5b3e4d8d117b2590c6485ff4b
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
Yes
Uploaded via twine/4.0.2 CPython/3.11.5

Release files / gssapi-1.8.3-cp312-cp312-win32.whl

Download URL gssapi-1.8.3-cp312-cp312-win32.whl
Size 768.8 kB
Tags CPython 3.12 Windows x86-32
SHA-256 checksum
How to use checksums
338db18612e3e6ed64e92b6d849242a535fdc98b365f21122992fb8cae737617
BLAKE2b-256 checksum
How to use checksums
5ba1bd70c11f7b93aba830d8ade56924b036ca39390470f2aeadd0fb381bdf13
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
Yes
Uploaded via twine/4.0.2 CPython/3.11.5

Release files / gssapi-1.8.3-cp312-cp312-macosx_11_0_arm64.whl

Download URL gssapi-1.8.3-cp312-cp312-macosx_11_0_arm64.whl
Size 685.8 kB
Tags CPython 3.12 macOS 11.0+ ARM64
SHA-256 checksum
How to use checksums
37f1a8046d695f2c9b8d640a6e385780d3945c0741571ed6fee6f94c31e431dc
BLAKE2b-256 checksum
How to use checksums
9c58b1415f5fa88db2448ccad7fc8536ab36622d064d5570b8fd40e548d2be6c
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
Yes
Uploaded via twine/4.0.2 CPython/3.11.5

Release files / gssapi-1.8.3-cp312-cp312-macosx_10_9_x86_64.whl

Download URL gssapi-1.8.3-cp312-cp312-macosx_10_9_x86_64.whl
Size 705.7 kB
Tags CPython 3.12 macOS 10.9+ x86-64
SHA-256 checksum
How to use checksums
19c373b3ba63ce19cd3163aa1495635e3d01b0de6cc4ff1126095eded1df6e01
BLAKE2b-256 checksum
How to use checksums
4ca6cba65106d456342dde6fb3001a2db727ef6e16ac1df1f07ac3c0347a5dde
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
Yes
Uploaded via twine/4.0.2 CPython/3.11.5

Release files / gssapi-1.8.3-cp311-cp311-win_amd64.whl

Download URL gssapi-1.8.3-cp311-cp311-win_amd64.whl
Size 871.9 kB
Tags CPython 3.11 Windows x86-64
SHA-256 checksum
How to use checksums
8fdb1ff130cee49bc865ec1624dee8cf445cd6c6e93b04bffef2c6f363a60cb9
BLAKE2b-256 checksum
How to use checksums
b6f0b1cc4a4ac8669878bd84fc0cf358d5bfa66773a050f8bfb3c2bf4d68a373
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
Yes
Uploaded via twine/4.0.2 CPython/3.11.5

Release files / gssapi-1.8.3-cp311-cp311-win32.whl

Download URL gssapi-1.8.3-cp311-cp311-win32.whl
Size 772.1 kB
Tags CPython 3.11 Windows x86-32
SHA-256 checksum
How to use checksums
edc8ef3a9e397dbe18bb6016f8e2209969677b534316d20bb139da2865a38efe
BLAKE2b-256 checksum
How to use checksums
9dbb95474f6627c7b4619f56321b25c0462228b503136df194eaced46fc2d192
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
Yes
Uploaded via twine/4.0.2 CPython/3.11.5

Release files / gssapi-1.8.3-cp311-cp311-macosx_11_0_arm64.whl

Download URL gssapi-1.8.3-cp311-cp311-macosx_11_0_arm64.whl
Size 687.7 kB
Tags CPython 3.11 macOS 11.0+ ARM64
SHA-256 checksum
How to use checksums
ca6ceb17fc15eda2a69f2e8c6cf10d11e2edb32832255e5d4c65b21b6db4680a
BLAKE2b-256 checksum
How to use checksums
0ac43b62db3b869e6a655f1d95f1ffe8a05777df32ed2b786da0ba963d863d45
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
Yes
Uploaded via twine/4.0.2 CPython/3.11.5

Release files / gssapi-1.8.3-cp311-cp311-macosx_10_9_x86_64.whl

Download URL gssapi-1.8.3-cp311-cp311-macosx_10_9_x86_64.whl
Size 711.9 kB
Tags CPython 3.11 macOS 10.9+ x86-64
SHA-256 checksum
How to use checksums
b03d6b30f1fcd66d9a688b45a97e302e4dd3f1386d5c333442731aec73cdb409
BLAKE2b-256 checksum
How to use checksums
60b095578131e7826e200a84bb1c4af9d75fd7f2f402be142c7f16f74bbf9dd2
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
Yes
Uploaded via twine/4.0.2 CPython/3.11.5

Release files / gssapi-1.8.3-cp310-cp310-win_amd64.whl

Download URL gssapi-1.8.3-cp310-cp310-win_amd64.whl
Size 867.7 kB
Tags CPython 3.10 Windows x86-64
SHA-256 checksum
How to use checksums
b031c0f186ab4275186da385b2c7470dd47c9b27522cb3b753757c9ac4bebf11
BLAKE2b-256 checksum
How to use checksums
86780576459f99b985ccfcd9864d4eff98f22b300e31a2246afaa5e7e58f70dd
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
Yes
Uploaded via twine/4.0.2 CPython/3.11.5

Release files / gssapi-1.8.3-cp310-cp310-win32.whl

Download URL gssapi-1.8.3-cp310-cp310-win32.whl
Size 771.7 kB
Tags CPython 3.10 Windows x86-32
SHA-256 checksum
How to use checksums
3a3f63105f39c4af29ffc8f7b6542053d87fe9d63010c689dd9a9f5571facb8e
BLAKE2b-256 checksum
How to use checksums
6f81f4d31e1b0fdf1644030feae2340280a6dcb1be87779e2c96b64c4bb0a900
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
Yes
Uploaded via twine/4.0.2 CPython/3.11.5

Release files / gssapi-1.8.3-cp310-cp310-macosx_11_0_arm64.whl

Download URL gssapi-1.8.3-cp310-cp310-macosx_11_0_arm64.whl
Size 684.9 kB
Tags CPython 3.10 macOS 11.0+ ARM64
SHA-256 checksum
How to use checksums
8d57d67547e18f4e44a688bfb20abbf176d1b8df547da2b31c3f2df03cfdc269
BLAKE2b-256 checksum
How to use checksums
d6d6af2397cb5ab9489fd181e0203abe31c338e9ea2cc6a865880edce4a2a125
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
Yes
Uploaded via twine/4.0.2 CPython/3.11.5

Release files / gssapi-1.8.3-cp310-cp310-macosx_10_9_x86_64.whl

Download URL gssapi-1.8.3-cp310-cp310-macosx_10_9_x86_64.whl
Size 708.2 kB
Tags CPython 3.10 macOS 10.9+ x86-64
SHA-256 checksum
How to use checksums
4e4a83e9b275fe69b5d40be6d5479889866b80333a12c51a9243f2712d4f0554
BLAKE2b-256 checksum
How to use checksums
d898dc84ff813aac87a307ad90191617d8af801023c5da6d3f02f7faab3d4304
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
Yes
Uploaded via twine/4.0.2 CPython/3.11.5

Release files / gssapi-1.8.3-cp39-cp39-win_amd64.whl

Download URL gssapi-1.8.3-cp39-cp39-win_amd64.whl
Size 871.0 kB
Tags CPython 3.9 Windows x86-64
SHA-256 checksum
How to use checksums
8fb8ee70458f47b51ed881a6881f30b187c987c02af16cc0fff0079255d4d465
BLAKE2b-256 checksum
How to use checksums
a94274436dc8eea4b7909a2b9d9d6c978be5825bb3dc081d08721df08dd2cdc0
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
Yes
Uploaded via twine/4.0.2 CPython/3.11.5

Release files / gssapi-1.8.3-cp39-cp39-win32.whl

Download URL gssapi-1.8.3-cp39-cp39-win32.whl
Size 774.4 kB
Tags CPython 3.9 Windows x86-32
SHA-256 checksum
How to use checksums
465c6788f2ac6ef7c738394ba8fde1ede6004e5721766f386add63891d8c90af
BLAKE2b-256 checksum
How to use checksums
f659cb21141abefc72319ab599af2be02343836af75c042b52fbc457275b2c87
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
Yes
Uploaded via twine/4.0.2 CPython/3.11.5

Release files / gssapi-1.8.3-cp39-cp39-macosx_11_0_arm64.whl

Download URL gssapi-1.8.3-cp39-cp39-macosx_11_0_arm64.whl
Size 688.6 kB
Tags CPython 3.9 macOS 11.0+ ARM64
SHA-256 checksum
How to use checksums
ee74b9211c977b9181ff4652d886d7712c9a221560752a35393b58e5ea07887a
BLAKE2b-256 checksum
How to use checksums
f157a750efc7db3a01fd437419366db27c09e4e749d65b213ca3778cedc6b3c4
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
Yes
Uploaded via twine/4.0.2 CPython/3.11.5

Release files / gssapi-1.8.3-cp39-cp39-macosx_10_9_x86_64.whl

Download URL gssapi-1.8.3-cp39-cp39-macosx_10_9_x86_64.whl
Size 712.0 kB
Tags CPython 3.9 macOS 10.9+ x86-64
SHA-256 checksum
How to use checksums
e40efc88ccefefd6142f8c47b8af498731938958b808bad49990442a91f45160
BLAKE2b-256 checksum
How to use checksums
3873320146be5ec8490fd17c7b649ae1a901ffe88db6152f6ceae8ed5af65d41
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
Yes
Uploaded via twine/4.0.2 CPython/3.11.5

Release files / gssapi-1.8.3-cp38-cp38-win_amd64.whl

Download URL gssapi-1.8.3-cp38-cp38-win_amd64.whl
Size 873.8 kB
Tags CPython 3.8 Windows x86-64
SHA-256 checksum
How to use checksums
5b4bf84d0a6d7779a4bf11dacfd3db57ae02dd53562e2aeadac4219a68eaee07
BLAKE2b-256 checksum
How to use checksums
8c386c4b411d255af31c2cd24cba287df6d9f380b905c2338d9eea1eda313e9a
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
Yes
Uploaded via twine/4.0.2 CPython/3.11.5

Release files / gssapi-1.8.3-cp38-cp38-win32.whl

Download URL gssapi-1.8.3-cp38-cp38-win32.whl
Size 776.5 kB
Tags CPython 3.8 Windows x86-32
SHA-256 checksum
How to use checksums
791e44f7bea602b8e3da1ec56fbdb383b8ee3326fdeb736f904c2aa9af13a67d
BLAKE2b-256 checksum
How to use checksums
50915d7ea93393ef41a0a4679ef2f83f8ba1c2bb4436eb51762f9efe6abd1efe
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
Yes
Uploaded via twine/4.0.2 CPython/3.11.5

Release files / gssapi-1.8.3-cp38-cp38-macosx_11_0_arm64.whl

Download URL gssapi-1.8.3-cp38-cp38-macosx_11_0_arm64.whl
Size 694.3 kB
Tags CPython 3.8 macOS 11.0+ ARM64
SHA-256 checksum
How to use checksums
d5b28237afc0668046934792756dd4b6b7e957b0d95a608d02f296734a2819ad
BLAKE2b-256 checksum
How to use checksums
8e956c4f2ab578a228289a9589f6a73571dbe6a1127e8dba22ea39262fd7c410
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
Yes
Uploaded via twine/4.0.2 CPython/3.11.5

Release files / gssapi-1.8.3-cp38-cp38-macosx_10_9_x86_64.whl

Download URL gssapi-1.8.3-cp38-cp38-macosx_10_9_x86_64.whl
Size 718.2 kB
Tags CPython 3.8 macOS 10.9+ x86-64
SHA-256 checksum
How to use checksums
7d91fe6e2a5c89b32102ea8e374b8ae13b9031d43d7b55f3abc1f194ddce820d
BLAKE2b-256 checksum
How to use checksums
dd6247c5932d5e61cdcf256cffec790ec04560d6fa11031bcb0a20271796d4e2
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
Yes
Uploaded via twine/4.0.2 CPython/3.11.5

Release files / gssapi-1.8.3-cp37-cp37m-win_amd64.whl

Download URL gssapi-1.8.3-cp37-cp37m-win_amd64.whl
Size 878.6 kB
Tags CPython 3.7 CPython 3.7 pymalloc Windows x86-64
SHA-256 checksum
How to use checksums
4d9ed83f2064cda60aad90e6840ae282096801b2c814b8cbd390bf0df4635aab
BLAKE2b-256 checksum
How to use checksums
5f17827950d829e7dda30d3caee816ba6575ea7567d52449bca26d439342c8b8
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
Yes
Uploaded via twine/4.0.2 CPython/3.11.5

Release files / gssapi-1.8.3-cp37-cp37m-win32.whl

Download URL gssapi-1.8.3-cp37-cp37m-win32.whl
Size 775.9 kB
Tags CPython 3.7 CPython 3.7 pymalloc Windows x86-32
SHA-256 checksum
How to use checksums
e2bb081f2db2111377effe7d40ba23f9a87359b9d2f4881552b731e9da88b36b
BLAKE2b-256 checksum
How to use checksums
338c8a83421aa13fa351a08e9de8a42edc1580e6b001eee1bfd2cf3707e65971
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
Yes
Uploaded via twine/4.0.2 CPython/3.11.5

Release files / gssapi-1.8.3-cp37-cp37m-macosx_10_9_x86_64.whl

Download URL gssapi-1.8.3-cp37-cp37m-macosx_10_9_x86_64.whl
Size 716.0 kB
Tags CPython 3.7 CPython 3.7 pymalloc macOS 10.9+ x86-64
SHA-256 checksum
How to use checksums
e556878da197ad115a566d36e46a8082d0079731d9c24d1ace795132d725ff2a
BLAKE2b-256 checksum
How to use checksums
2996a1d4b20567909c76780bf7ee15796b8c422cad719a6fa15c6068c291110c
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
Yes
Uploaded via twine/4.0.2 CPython/3.11.5
Anthropic, PBC Visionary sponsor Bloomberg Visionary sponsor Hudson River Trading Visionary sponsor Meta Visionary sponsor NVIDIA Visionary sponsor Microsoft Sustainability sponsor Depot Continuous Integration AWS Cloud computing and Security Sponsor Datadog Monitoring Fastly CDN Google Download Analytics Sentry Error logging StatusPage Status page