Skip to main content
https://badge.fury.io/gh/pythongssapi%2Fpython-gssapi.svg https://badge.fury.io/py/gssapi.svg

Python-GSSAPI provides both low-level and high level wrappers around the GSSAPI C libraries. While it focuses on the Kerberos mechanism, it should also be useable with other GSSAPI mechanisms.

Documentation can be found at https://pythongssapi.github.io/python-gssapi/.

Requirements

Basic

  • A working implementation of GSSAPI (such as from MIT Kerberos) which supports delegation and includes header files

  • a C compiler (such as GCC)

  • Python 3.8+ (older releases support older versions, but are unsupported)

  • the decorator python package

Compiling from Scratch

To compile from scratch, you will need Cython >= 3.0.3, < 4.0.0 which is automatically installed by pip in an isolated build virtual environment.

For Running the Tests

  • the k5test package

To install test dependencies using pip:

$ pip install -r test-requirements.txt # Optional, for running test suite

Installation

Easy Way

$ pip install gssapi

From the Git Repo

After being sure to install all the requirements,

$ git clone https://github.com/pythongssapi/python-gssapi.git
$ pip install .

Tests

The tests for for Python-GSSAPI live in gssapi.tests. In order to run the tests, you must have an MIT Kerberos installation (including the KDC). The tests create a self-contained Kerberos setup, so running the tests will not interfere with any existing Kerberos installations.

Structure

Python-GSSAPI is composed of two parts: a low-level C-style API which thinly wraps the underlying RFC 2744 methods, and a high-level, Pythonic API (which is itself a wrapper around the low-level API). Examples may be found in the examples directory.

Low-Level API

The low-level API lives in gssapi.raw. The methods contained therein are designed to match closely with the original GSSAPI C methods. All relevant methods and classes may be imported directly from gssapi.raw. Extension methods will only be imported if they are present. The low-level API follows the given format:

  • Names match the RFC 2744 specification, with the gssapi_ prefix removed

  • Parameters which use C int constants as enums have enum.IntEnum classes defined, and thus may be passed either the enum members or integers

  • In cases where a specific constant is passed in the C API to represent a default value, None should be passed instead

  • In cases where non-integer constants would be used in the API (i.e. OIDs), enum-like objects have been defined containing named references to values specified in RFC 2744.

  • Major and minor error codes are returned by raising gssapi.raw.GSSError. The major error codes have exceptions defined in in gssapi.raw.exceptions to make it easier to catch specific errors or categories of errors.

  • All other relevant output values are returned via named tuples.

High-Level API

The high-level API lives directly under gssapi. The classes contained in each file are designed to provide a more Pythonic, Object-Oriented view of GSSAPI. The exceptions from the low-level API, plus several additional exceptions, live in gssapi.exceptions. The rest of the classes may be imported directly from gssapi. Only classes are exported by gssapi – all functions are methods of classes in the high-level API.

Please note that QoP is not supported in the high-level API, since it has been deprecated.

Extensions

In addition to RFC 2743/2744, Python-GSSAPI also has support for:

  • RFC 4178 (GSS-API Negotiation Mechanism)

  • RFC 5587 (Extended GSS Mechanism Inquiry APIs)

  • RFC 5588 (GSS-API Extension for Storing Delegated Credentials)

  • RFC 5801 (GSS-API SASL Extensions)

  • (Additional) Credential Store Extension

  • Services4User

  • Credentials import-export

  • RFC 6680 (GSS-API Naming Extensions)

  • DCE and IOV MIC extensions

  • acquire_cred_with_password and add_cred_with_password

  • GGF Extensions

  • Kerberos specific extensions

The Team

(GitHub usernames in parentheses)

  • Jordan Borean (@jborean93) - current maintainer and developer

  • Simo Sorce (@simo5) - developer

  • Robbie Harwood (@frozencemetery) - author emeritus

  • Solly Ross (@directxman12) - author emeritus

  • Hugh Cole-Baker (@sigmaris) - author emeritus

Get Involved

We welcome new contributions in the form of Issues and Pull Requests on Github. If you would like to join our discussions, you can find us on libera.chat IRC, channel #python-gssapi.

Metadata

Release files for gssapi 1.9.0

For a detailed explanation of source distributions (sdists) and built distributions (wheels), please see the package formats documentation.

Source distribution (sdist)

Source distribution for gssapi 1.9.0
File Size Uploaded
gssapi-1.9.0.tar.gz 94.3 kB Details

Built distributions (wheels)

Table of built distributions (wheels) for gssapi 1.9.0
File
gssapi-1.9.0-cp313-cp313-win_amd64.whl CPython 3.13 CPython 3.13 Windows x86-64 Details
gssapi-1.9.0-cp313-cp313-win32.whl CPython 3.13 CPython 3.13 Windows x86-32 Details
gssapi-1.9.0-cp313-cp313-macosx_11_0_arm64.whl CPython 3.13 CPython 3.13 macOS 11.0+ ARM64 Details
gssapi-1.9.0-cp313-cp313-macosx_10_13_x86_64.whl CPython 3.13 CPython 3.13 macOS 10.13+ x86-64 Details
gssapi-1.9.0-cp312-cp312-win_amd64.whl CPython 3.12 CPython 3.12 Windows x86-64 Details
gssapi-1.9.0-cp312-cp312-win32.whl CPython 3.12 CPython 3.12 Windows x86-32 Details
gssapi-1.9.0-cp312-cp312-macosx_11_0_arm64.whl CPython 3.12 CPython 3.12 macOS 11.0+ ARM64 Details
gssapi-1.9.0-cp312-cp312-macosx_10_13_x86_64.whl CPython 3.12 CPython 3.12 macOS 10.13+ x86-64 Details
gssapi-1.9.0-cp311-cp311-win_amd64.whl CPython 3.11 CPython 3.11 Windows x86-64 Details
gssapi-1.9.0-cp311-cp311-win32.whl CPython 3.11 CPython 3.11 Windows x86-32 Details
gssapi-1.9.0-cp311-cp311-macosx_11_0_arm64.whl CPython 3.11 CPython 3.11 macOS 11.0+ ARM64 Details
gssapi-1.9.0-cp311-cp311-macosx_10_9_x86_64.whl CPython 3.11 CPython 3.11 macOS 10.9+ x86-64 Details
gssapi-1.9.0-cp310-cp310-win_amd64.whl CPython 3.10 CPython 3.10 Windows x86-64 Details
gssapi-1.9.0-cp310-cp310-win32.whl CPython 3.10 CPython 3.10 Windows x86-32 Details
gssapi-1.9.0-cp310-cp310-macosx_11_0_arm64.whl CPython 3.10 CPython 3.10 macOS 11.0+ ARM64 Details
gssapi-1.9.0-cp310-cp310-macosx_10_9_x86_64.whl CPython 3.10 CPython 3.10 macOS 10.9+ x86-64 Details
gssapi-1.9.0-cp39-cp39-win_amd64.whl CPython 3.9 CPython 3.9 Windows x86-64 Details
gssapi-1.9.0-cp39-cp39-win32.whl CPython 3.9 CPython 3.9 Windows x86-32 Details
gssapi-1.9.0-cp39-cp39-macosx_11_0_arm64.whl CPython 3.9 CPython 3.9 macOS 11.0+ ARM64 Details
gssapi-1.9.0-cp39-cp39-macosx_10_9_x86_64.whl CPython 3.9 CPython 3.9 macOS 10.9+ x86-64 Details
gssapi-1.9.0-cp38-cp38-win_amd64.whl CPython 3.8 CPython 3.8 Windows x86-64 Details
gssapi-1.9.0-cp38-cp38-win32.whl CPython 3.8 CPython 3.8 Windows x86-32 Details
gssapi-1.9.0-cp38-cp38-macosx_11_0_arm64.whl CPython 3.8 CPython 3.8 macOS 11.0+ ARM64 Details
gssapi-1.9.0-cp38-cp38-macosx_10_9_x86_64.whl CPython 3.8 CPython 3.8 macOS 10.9+ x86-64 Details

Total release size: 18.3 MB

Release files / gssapi-1.9.0.tar.gz

Download URL gssapi-1.9.0.tar.gz
Size 94.3 kB
Tags Source
SHA-256 checksum
How to use checksums
f468fac8f3f5fca8f4d1ca19e3cd4d2e10bd91074e7285464b22715d13548afe
BLAKE2b-256 checksum
How to use checksums
042ffcffb772a00e658f608e657791484e3111a19a722b464e893fef35f35097
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
Yes
Uploaded via twine/5.1.1 CPython/3.12.7

Release files / gssapi-1.9.0-cp313-cp313-win_amd64.whl

Download URL gssapi-1.9.0-cp313-cp313-win_amd64.whl
Size 845.0 kB
Tags CPython 3.13 Windows x86-64
SHA-256 checksum
How to use checksums
a2e43f50450e81fe855888c53df70cdd385ada979db79463b38031710a12acd9
BLAKE2b-256 checksum
How to use checksums
6700f4be5211d5dd8e9ca551ded3071b1433880729006768123e1ee7b744b1d8
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
Yes
Uploaded via twine/5.1.1 CPython/3.12.7

Release files / gssapi-1.9.0-cp313-cp313-win32.whl

Download URL gssapi-1.9.0-cp313-cp313-win32.whl
Size 755.4 kB
Tags CPython 3.13 Windows x86-32
SHA-256 checksum
How to use checksums
c99959a9dd62358e370482f1691e936cb09adf9a69e3e10d4f6a097240e9fd28
BLAKE2b-256 checksum
How to use checksums
5ff73d9d4a198e34b844dc4acb25891e2405f8dca069a8f346f51127196436bc
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
Yes
Uploaded via twine/5.1.1 CPython/3.12.7

Release files / gssapi-1.9.0-cp313-cp313-macosx_11_0_arm64.whl

Download URL gssapi-1.9.0-cp313-cp313-macosx_11_0_arm64.whl
Size 672.2 kB
Tags CPython 3.13 macOS 11.0+ ARM64
SHA-256 checksum
How to use checksums
1a5786bd9fcf435bd0c87dc95ae99ad68cefcc2bcc80c71fef4cb0ccdfb40f1e
BLAKE2b-256 checksum
How to use checksums
c97289eeb28a2cebe8ec3a560be79e89092913d6cf9dc68b32eb4774e8bac785
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
Yes
Uploaded via twine/5.1.1 CPython/3.12.7

Release files / gssapi-1.9.0-cp313-cp313-macosx_10_13_x86_64.whl

Download URL gssapi-1.9.0-cp313-cp313-macosx_10_13_x86_64.whl
Size 686.9 kB
Tags CPython 3.13 macOS 10.13+ x86-64
SHA-256 checksum
How to use checksums
cea344246935b5337e6f8a69bb6cc45619ab3a8d74a29fcb0a39fd1e5843c89c
BLAKE2b-256 checksum
How to use checksums
bcbb6fbbeff852b6502e1d33858865822ab2e0efd84764caad1ce9e3ed182b53
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
Yes
Uploaded via twine/5.1.1 CPython/3.12.7

Release files / gssapi-1.9.0-cp312-cp312-win_amd64.whl

Download URL gssapi-1.9.0-cp312-cp312-win_amd64.whl
Size 867.6 kB
Tags CPython 3.12 Windows x86-64
SHA-256 checksum
How to use checksums
e28c7d45da68b7e36ed3fb3326744bfe39649f16e8eecd7b003b082206039c76
BLAKE2b-256 checksum
How to use checksums
c17333a65e9d6c5ea43cdb1ee184b201678adaf3a7bbb4f7a1c7a80195c884ac
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
Yes
Uploaded via twine/5.1.1 CPython/3.12.7

Release files / gssapi-1.9.0-cp312-cp312-win32.whl

Download URL gssapi-1.9.0-cp312-cp312-win32.whl
Size 770.3 kB
Tags CPython 3.12 Windows x86-32
SHA-256 checksum
How to use checksums
10134db0cf01bd7d162acb445762dbcc58b5c772a613e17c46cf8ad956c4dfec
BLAKE2b-256 checksum
How to use checksums
714b4cbb8b6bc34ed02591e05af48bd4722facb99b10defc321e3b177114dbeb
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
Yes
Uploaded via twine/5.1.1 CPython/3.12.7

Release files / gssapi-1.9.0-cp312-cp312-macosx_11_0_arm64.whl

Download URL gssapi-1.9.0-cp312-cp312-macosx_11_0_arm64.whl
Size 681.6 kB
Tags CPython 3.12 macOS 11.0+ ARM64
SHA-256 checksum
How to use checksums
2bddd1cc0c9859c5e0fd96d4d88eb67bd498fdbba45b14cdccfe10bfd329479f
BLAKE2b-256 checksum
How to use checksums
9634b737e2a46efc63c6a6ad3baf0f3a8484d7698e673874b060a7d52abfa7b4
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
Yes
Uploaded via twine/5.1.1 CPython/3.12.7

Release files / gssapi-1.9.0-cp312-cp312-macosx_10_13_x86_64.whl

Download URL gssapi-1.9.0-cp312-cp312-macosx_10_13_x86_64.whl
Size 698.1 kB
Tags CPython 3.12 macOS 10.13+ x86-64
SHA-256 checksum
How to use checksums
b66a98827fbd2864bf8993677a039d7ba4a127ca0d2d9ed73e0ef4f1baa7fd7f
BLAKE2b-256 checksum
How to use checksums
98f176477c66aa9f2abc9ab53f936e9085402d6697db93834437e5ee651e5106
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
Yes
Uploaded via twine/5.1.1 CPython/3.12.7

Release files / gssapi-1.9.0-cp311-cp311-win_amd64.whl

Download URL gssapi-1.9.0-cp311-cp311-win_amd64.whl
Size 874.2 kB
Tags CPython 3.11 Windows x86-64
SHA-256 checksum
How to use checksums
59e1a1a9a6c5dc430dc6edfcf497f5ca00cf417015f781c9fac2e85652cd738f
BLAKE2b-256 checksum
How to use checksums
31073bb8521da3ca89e202b50f8de46a9e8e793be7f24318a4f7aaaa022d15d1
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
Yes
Uploaded via twine/5.1.1 CPython/3.12.7

Release files / gssapi-1.9.0-cp311-cp311-win32.whl

Download URL gssapi-1.9.0-cp311-cp311-win32.whl
Size 776.5 kB
Tags CPython 3.11 Windows x86-32
SHA-256 checksum
How to use checksums
6c5f8a549abd187687440ec0b72e5b679d043d620442b3637d31aa2766b27cbe
BLAKE2b-256 checksum
How to use checksums
0529b673b4ed994796e133e3e7eeec0d8991b7dcbed6b0b4bfc95ac0fe3871ff
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
Yes
Uploaded via twine/5.1.1 CPython/3.12.7

Release files / gssapi-1.9.0-cp311-cp311-macosx_11_0_arm64.whl

Download URL gssapi-1.9.0-cp311-cp311-macosx_11_0_arm64.whl
Size 683.8 kB
Tags CPython 3.11 macOS 11.0+ ARM64
SHA-256 checksum
How to use checksums
11e9b92cef11da547fc8c210fa720528fd854038504103c1b15ae2a89dce5fcd
BLAKE2b-256 checksum
How to use checksums
cc045d46c5b37b96f87a8efb320ab347e876db2493e1aedaa29068936b063097
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
Yes
Uploaded via twine/5.1.1 CPython/3.12.7

Release files / gssapi-1.9.0-cp311-cp311-macosx_10_9_x86_64.whl

Download URL gssapi-1.9.0-cp311-cp311-macosx_10_9_x86_64.whl
Size 707.9 kB
Tags CPython 3.11 macOS 10.9+ x86-64
SHA-256 checksum
How to use checksums
67d9be5e34403e47fb5749d5a1ad4e5a85b568e6a9add1695edb4a5b879f7560
BLAKE2b-256 checksum
How to use checksums
d11439d320ac0c8c8ab05f4b48322d38aacb1572f7a51b2c5b908e51f141e367
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
Yes
Uploaded via twine/5.1.1 CPython/3.12.7

Release files / gssapi-1.9.0-cp310-cp310-win_amd64.whl

Download URL gssapi-1.9.0-cp310-cp310-win_amd64.whl
Size 870.7 kB
Tags CPython 3.10 Windows x86-64
SHA-256 checksum
How to use checksums
dfc1b4c0bfe9f539537601c9f187edc320daf488f694e50d02d0c1eb37416962
BLAKE2b-256 checksum
How to use checksums
16fd5e073a430ced9babe0accde37c0a645124da475a617dfc741af1fff59e78
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
Yes
Uploaded via twine/5.1.1 CPython/3.12.7

Release files / gssapi-1.9.0-cp310-cp310-win32.whl

Download URL gssapi-1.9.0-cp310-cp310-win32.whl
Size 778.9 kB
Tags CPython 3.10 Windows x86-32
SHA-256 checksum
How to use checksums
2a9c745255e3a810c3e8072e267b7b302de0705f8e9a0f2c5abc92fe12b9475e
BLAKE2b-256 checksum
How to use checksums
188c1ea407d8c60be3e3e3c1d07e7b2ef3c94666e89289b9267b0ca265d2b8aa
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
Yes
Uploaded via twine/5.1.1 CPython/3.12.7

Release files / gssapi-1.9.0-cp310-cp310-macosx_11_0_arm64.whl

Download URL gssapi-1.9.0-cp310-cp310-macosx_11_0_arm64.whl
Size 684.7 kB
Tags CPython 3.10 macOS 11.0+ ARM64
SHA-256 checksum
How to use checksums
14a1ae12fdf1e4c8889206195ba1843de09fe82587fa113112887cd5894587c6
BLAKE2b-256 checksum
How to use checksums
3a7954f11022e09d214b3c037f9fd0c91f0a876b225e884770ef81e7dfbe0903
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
Yes
Uploaded via twine/5.1.1 CPython/3.12.7

Release files / gssapi-1.9.0-cp310-cp310-macosx_10_9_x86_64.whl

Download URL gssapi-1.9.0-cp310-cp310-macosx_10_9_x86_64.whl
Size 708.1 kB
Tags CPython 3.10 macOS 10.9+ x86-64
SHA-256 checksum
How to use checksums
261e00ac426d840055ddb2199f4989db7e3ce70fa18b1538f53e392b4823e8f1
BLAKE2b-256 checksum
How to use checksums
8947aa7f24009de06c6a20f7eee2c4accfea615452875dc15c44e5dc3292722d
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
Yes
Uploaded via twine/5.1.1 CPython/3.12.7

Release files / gssapi-1.9.0-cp39-cp39-win_amd64.whl

Download URL gssapi-1.9.0-cp39-cp39-win_amd64.whl
Size 874.0 kB
Tags CPython 3.9 Windows x86-64
SHA-256 checksum
How to use checksums
11c9fe066edb0fa0785697eb0cecf2719c7ad1d9f2bf27be57b647a617bcfaa5
BLAKE2b-256 checksum
How to use checksums
88142a448c2d4a5a29b6471ef1202fa151cf3a9a5210b913a7b1e9f323d3345f
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
Yes
Uploaded via twine/5.1.1 CPython/3.12.7

Release files / gssapi-1.9.0-cp39-cp39-win32.whl

Download URL gssapi-1.9.0-cp39-cp39-win32.whl
Size 781.6 kB
Tags CPython 3.9 Windows x86-32
SHA-256 checksum
How to use checksums
060b58b455d29ab8aca74770e667dca746264bee660ac5b6a7a17476edc2c0b8
BLAKE2b-256 checksum
How to use checksums
e9b88a100d57d9723aba471a557153cb48c517920221e9e5e8ed94046e3652bc
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
Yes
Uploaded via twine/5.1.1 CPython/3.12.7

Release files / gssapi-1.9.0-cp39-cp39-macosx_11_0_arm64.whl

Download URL gssapi-1.9.0-cp39-cp39-macosx_11_0_arm64.whl
Size 688.4 kB
Tags CPython 3.9 macOS 11.0+ ARM64
SHA-256 checksum
How to use checksums
5b2a3c0a9beb895942d4b8e31f515e52c17026e55aeaa81ee0df9bbfdac76098
BLAKE2b-256 checksum
How to use checksums
84d3731b84430ed06fbf3f1e07b265a5f6880dfbcf17c665383b5f616307034b
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
Yes
Uploaded via twine/5.1.1 CPython/3.12.7

Release files / gssapi-1.9.0-cp39-cp39-macosx_10_9_x86_64.whl

Download URL gssapi-1.9.0-cp39-cp39-macosx_10_9_x86_64.whl
Size 712.1 kB
Tags CPython 3.9 macOS 10.9+ x86-64
SHA-256 checksum
How to use checksums
cbc93fdadd5aab9bae594538b2128044b8c5cdd1424fe015a465d8a8a587411a
BLAKE2b-256 checksum
How to use checksums
f1b7a4406651de13fced3c1ea18ddb52fbd19498deaf62c5d76df2a6bc10a4b0
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
Yes
Uploaded via twine/5.1.1 CPython/3.12.7

Release files / gssapi-1.9.0-cp38-cp38-win_amd64.whl

Download URL gssapi-1.9.0-cp38-cp38-win_amd64.whl
Size 879.3 kB
Tags CPython 3.8 Windows x86-64
SHA-256 checksum
How to use checksums
a81f30cde21031e7b1f8194a3eea7285e39e551265e7744edafd06eadc1c95bc
BLAKE2b-256 checksum
How to use checksums
43cef5c2c19ebe208e3323e18c6139a1b3ad6b601c4418665cd2e166bcfece37
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
Yes
Uploaded via twine/5.1.1 CPython/3.12.7

Release files / gssapi-1.9.0-cp38-cp38-win32.whl

Download URL gssapi-1.9.0-cp38-cp38-win32.whl
Size 784.8 kB
Tags CPython 3.8 Windows x86-32
SHA-256 checksum
How to use checksums
f2f3a46784d8127cc7ef10d3367dedcbe82899ea296710378ccc9b7cefe96f4c
BLAKE2b-256 checksum
How to use checksums
fc101ad7d3e3315dd060a5a40e09741cd1b75637bbe009677722dcb261682532
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
Yes
Uploaded via twine/5.1.1 CPython/3.12.7

Release files / gssapi-1.9.0-cp38-cp38-macosx_11_0_arm64.whl

Download URL gssapi-1.9.0-cp38-cp38-macosx_11_0_arm64.whl
Size 692.8 kB
Tags CPython 3.8 macOS 11.0+ ARM64
SHA-256 checksum
How to use checksums
b74031c70864d04864b7406c818f41be0c1637906fb9654b06823bcc79f151dc
BLAKE2b-256 checksum
How to use checksums
2cdaa6844b39721feb90a79b6fec973649de1e75240f0e5b408f3265438a22ab
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
Yes
Uploaded via twine/5.1.1 CPython/3.12.7

Release files / gssapi-1.9.0-cp38-cp38-macosx_10_9_x86_64.whl

Download URL gssapi-1.9.0-cp38-cp38-macosx_10_9_x86_64.whl
Size 716.9 kB
Tags CPython 3.8 macOS 10.9+ x86-64
SHA-256 checksum
How to use checksums
c0e378d62b2fc352ca0046030cda5911d808a965200f612fdd1d74501b83e98f
BLAKE2b-256 checksum
How to use checksums
4d0c2af47de26a60db07fdf61e5b3edff995de692fce6243173d0fd0122c5067
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
Yes
Uploaded via twine/5.1.1 CPython/3.12.7
Anthropic, PBC Visionary sponsor Bloomberg Visionary sponsor Hudson River Trading Visionary sponsor Meta Visionary sponsor NVIDIA Visionary sponsor Microsoft Sustainability sponsor Depot Continuous Integration AWS Cloud computing and Security Sponsor Datadog Monitoring Fastly CDN Google Download Analytics Sentry Error logging StatusPage Status page