Skip to main content

Internationalized Domain Names in Applications (IDNA)

A library to support the Internationalised Domain Names in Applications (IDNA) protocol as specified in RFC 5891. This version of the protocol is often referred to as “IDNA2008”.

This library also provides support for Unicode Technical Standard 46, Unicode IDNA Compatibility Processing.

The library is also intended to act as a suitable replacement for the “encodings.idna” module that comes with the Python standard library but currently only supports the older, deprecated IDNA specification (RFC 3490).

Its basic functions are simply executed:

>>> import idna
>>> idna.encode(u'ドメイン.テスト')
'xn--eckwd4c7c.xn--zckzah'
>>> print idna.decode('xn--eckwd4c7c.xn--zckzah')
ドメイン.テスト

Packages

The latest tagged release version is published in the PyPI repository:

https://badge.fury.io/py/idna.svg

Installation

To install this library, you can use PIP:

$ pip install idna

Alternatively, you can install the package using the bundled setup script:

$ python setup.py install

This library should work with Python 2.7, and Python 3.3 or later.

Usage

For typical usage, the encode and decode functions will take a domain name argument and perform a conversion to an A-label or U-label respectively.

>>> import idna
>>> idna.encode(u'ドメイン.テスト')
'xn--eckwd4c7c.xn--zckzah'
>>> print idna.decode('xn--eckwd4c7c.xn--zckzah')
ドメイン.テスト

You may use the codec encoding and decoding methods using the idna.codec module.

>>> import idna.codec
>>> print u'домена.испытание'.encode('idna')
xn--80ahd1agd.xn--80akhbyknj4f
>>> print 'xn--80ahd1agd.xn--80akhbyknj4f'.decode('idna')
домена.испытание

Conversions can be applied at a per-label basis using the ulabel or alabel functions if necessary:

>>> idna.alabel(u'测试')
'xn--0zwm56d'

Compatibility Mapping (UTS #46)

As described in RFC 5895, the IDNA specification no longer including mappings from different forms of input that a user may enter, to the form that is provided to the IDNA functions. This functionality is now considered by the specification to be a local user-interface issue distinct from IDNA conversion functionality.

This library support one user-level mapping, that developed by the Unicode Consortium, known as Unicode IDNA Compatibility Processing. It provides for both regular mapping and transitional mapping.

For example, “Königsgäßchen” is not a permissible label as LATIN CAPITAL LETTER K is not allowed (as are capital letters in general). UTS46 will convert this into lower case.

>>> import idna
>>> idna.encode(u'Königsgäßchen')
...
idna.core.InvalidCodepoint: Codepoint U+004B at position 1 of u'K\xf6nigsg\xe4\xdfchen' not allowed
>>> idna.encode(u'Königsgäßchen', uts46=True)
'xn--knigsgchen-b4a3dun'

Transitional processing provides conversions to help transition from the older 2003 standard to the current standard. For example, in the original IDNA specification, the LATIN SMALL LETTER SHARP S (ß) was converted into two LATIN SMALL LETTER S (ss), whereas in the current IDNA specification this conversion is not performed.

>>> idna.encode(u'Königsgäßchen', uts46=True, transitional=True)
'xn--knigsgsschen-lcb0w'

Implementors should use transitional processing with caution, only in rare cases where conversion from legacy labels to current labels must be performed (i.e. IDNA implementations that pre-date 2008). For typical applications that just need to convert labels, transitional processing is unlikely to be beneficial and could produce unexpected incompatible results.

encodings.idna Compatibility

Function calls from the Python built-in encodings.idna module are mapping to their IDNA 2008 equivalents using the idna.compat module. Simply substitute the import clause in your code to refer to the new module name.

Exceptions

All errors raised during the conversion following the specification should raise an exception derived from the idna.IDNAError base class.

More specific exceptions that may be generated as idna.IDNABidiError when the error reflects an illegal combination of left-to-right and right-to-left characters in a label; idna.InvalidCodepoint when a specific codepoint is an illegal character in an IDN label (i.e. INVALID); and idna.InvalidCodepointContext when the codepoint is illegal based on its positional context (i.e. it is CONTEXTO or CONTEXTJ but the contextual requirements are not satisfied.)

Testing

The library has a test suite based on each rule of the IDNA specification, as well as test that are provided as part of the Unicode Technical Standard 46, Unicode IDNA Compatibility Processing.

The tests are run automatically on each commit to the master branch of the idna git repository at Travis CI:

https://travis-ci.org/kjd/idna.svg?branch=master

Metadata

Release files for idna 2.1

For a detailed explanation of source distributions (sdists) and built distributions (wheels), please see the package formats documentation.

Source distribution (sdist)

Source distribution for idna 2.1
File Size Uploaded
idna-2.1.tar.gz 129.0 kB Details

Built distributions (wheels)

Table of built distributions (wheels) for idna 2.1
File Interpreter ABI Platform
idna-2.1-py2.py3-none-any.whl Python 2, Python 3 none any Details
idna-2.1-py2-none-any.whl Python 2 none any Details

Total release size: 237.5 kB

Release files / idna-2.1.tar.gz

Download URL idna-2.1.tar.gz
Size 129.0 kB
Tags Source
SHA-256 checksum
How to use checksums
ed36f281aebf3cd0797f163bb165d84c31507cedd15928b095b1675e2d04c676
BLAKE2b-256 checksum
How to use checksums
fb848c27516fbaa8147acd2e431086b473c453c428e24e8fb99a1d89ce381851
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
No

Release files / idna-2.1-py2.py3-none-any.whl

Download URL idna-2.1-py2.py3-none-any.whl
Size 54.2 kB
Tags Python 2 Python 3
SHA-256 checksum
How to use checksums
f28df695e9bede8a19b18a8e4429b4bad4d664e8e98aff27bc39b630f1ae2b42
BLAKE2b-256 checksum
How to use checksums
7102dee75fc3e6f7455bf69221164f94586ee13552c5f33c8002335667a3d122
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
No

Release files / idna-2.1-py2-none-any.whl

Download URL idna-2.1-py2-none-any.whl
Size 54.2 kB
Tags Python 2
SHA-256 checksum
How to use checksums
4cfe64db2804351249d8d13ec1f3a2b0be9dc84b409b65c2a646c4d673fa55bc
BLAKE2b-256 checksum
How to use checksums
ffee57ca2b52dea2df65a15d4ab2669c89ff29fa227668917cebc43e689360be
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
No

Release history Release notifications | RSS feed

3.20

2 release files

3.19

2 release files

3.18

2 release files

3.17

2 release files

3.16

2 release files

3.15

2 release files

3.14

2 release files

3.13

2 release files

3.12

2 release files

3.11

2 release files

3.10

2 release files

3.9

2 release files

3.8

2 release files

3.7

2 release files

3.6

2 release files

3.5

2 release files

3.4

2 release files

3.3

2 release files

3.2

2 release files

3.1

2 release files

3.0

2 release files

2.10

2 release files

2.9

2 release files

2.8

2 release files

2.7

2 release files

2.6

2 release files

2.5

2 release files

2.4

2 release files

2.3

2 release files

2.2

2 release files

This release

2.1 This release

3 release files

2.0

2 release files

1.1

1 release file

1.0

1 release file

0.9

1 release file

0.8

1 release file

0.7

1 release file

0.6

1 release file

0.5

1 release file

0.4

1 release file

0.3

1 release file

0.2

1 release file

0.1

Anthropic, PBC Visionary sponsor Bloomberg Visionary sponsor Hudson River Trading Visionary sponsor Meta Visionary sponsor NVIDIA Visionary sponsor Microsoft Sustainability sponsor Depot Continuous Integration AWS Cloud computing and Security Sponsor Datadog Monitoring Fastly CDN Google Download Analytics Sentry Error logging StatusPage Status page