Skip to main content

JQuery datepicker based on 3c.form for Zope 3

Project description

This package provides a z3c.form datepicker based on JQuery for Zope3.

CHANGES

2.1.1 (2018-04-09)

  • bugfix: make sure we setup integer not string for weekStart
  • bugfix: set z-index, zIndexOffset from 10 to 1001
  • feature: added datePickerTitleFormatPattern used for title format pattern

2.1.0 (2018-02-25)

  • bugfix: update to newest boostratp.datepciker.js because the previous version was not compatible with jquery version 1.9 because the toggle method in jquery 1.9 got removed.

2.0.5 (2017-12-27)

  • bugfix: removed document ready wrapper for datepicker rendering. This allows to apply changeDate event trigger handler before or after rendering the datapicker. Without this improvement the event trigger get fired and handled each time we setup the widget. This is not what we need if we handle the changeDate event with jsonrpc
  • bugfix: fix broken widget startDate and endDate rendering. The date wasn’t wrapped with an apostroph and this broke javascript rendering.

2.0.4 (2015-08-10)

  • bugfix: bring back autoclose by default

2.0.3 (2015-08-10)

  • feature: added newest widget options
  • bugfix: fix issues with french tranlation. Use ” instead of ‘ in javascript code and prevent conflict with french translation.

2.0.2 (2015-07-20)

  • bugfix: fix encoding issues

2.0.1 (2015-06-30)

  • switch to newest javascript and styles version 1.4.0
  • bump version to 2.0.0 because it’s a part of j01.form since v2.0.0
  • don’t forget to include bootstrap dropdown styles or take a look at the standalone styles at: https://github.com/eternicode/bootstrap-datepicker/
  • bugfix: remove unused images

0.6.2 (2015-06-29)

  • bugfix: convert tabs to space in j01.datepicker.js

0.6.1 (2015-04-11)

  • bugfix: fix j01.datepicker.js include in configure.zcml

0.6.0 (2014-03-24)

  • feature: support bootstrap 3 based less and css concept. Just copy the core.less file and override the variables.
  • use j01.datepicker.css instead of datepicker.css and j01.datepicker.js instead of datepicker.js
  • switch from outdated eyecon datepicker to bootstrap-datepicker. Please review the implementation if you used customized widgets. At least inlclude j01.datepicker.js instead of datepicker.js.

0.5.2 (2013-06-20)

  • bugfix: fix date format translation. Use the correct message item.

0.5.1 (2013-03-19)

  • bugfix: fix german umlauts in months

0.5.0 (2012-11-16)

  • initial release

Project details


Release history Release notifications

This version
History Node

2.1.1

History Node

2.1.0

History Node

2.0.5

History Node

2.0.4

History Node

2.0.3

History Node

2.0.2

History Node

2.0.1

History Node

0.6.2

History Node

0.6.1

History Node

0.6.0

History Node

0.5.2

History Node

0.5.1

History Node

0.5.0

Download files

Download the file for your platform. If you're not sure which to choose, learn more about installing packages.

Filename, size & hash SHA256 hash help File type Python version Upload date
j01.datepicker-2.1.1.tar.gz (35.8 kB) Copy SHA256 hash SHA256 Source None Apr 9, 2018

Supported by

Elastic Elastic Search Pingdom Pingdom Monitoring Google Google BigQuery Sentry Sentry Error logging CloudAMQP CloudAMQP RabbitMQ AWS AWS Cloud computing DataDog DataDog Monitoring Fastly Fastly CDN DigiCert DigiCert EV certificate StatusPage StatusPage Status page