Skip to main content
Help us improve PyPI by participating in user testing. All experience levels needed!

Bundled HTML/JS/CSS compressor and data-uri embedding tools (YUICompressor, CSSEmbed, DataURI, Google Closure Compiler, HTMLCompressor, Google Closure Stylesheets)

Project description

Bundled HTML/CSS/JavaScript minifiers and data-uri embedding tools.

Installation

You need Python and Java installed on your system to be able to use Squeeze. Installing squeeze itself is easy with [pip](http://pypi.python.org/pypi/pip):

$ pip install squeeze

Usage

So you want to use the YUICompressor?

$ squeeze yuicompressor –help

How about the Google Closure Compiler?

$ squeeze closure –help

Ooh. What about CSSEmbed and HTML compressor?

$ squeeze cssembed –help $ squeeze htmlcompressor –help

Whee! More here:

$ squeeze –help

Licensing

Squeeze is released into the public domain. 3rd party libraries included with it, however, carry their own licensing.

Please see the LICENSE file in the source code for more information.

Project details


Release history Release notifications

This version
History Node

0.1.7

History Node

0.1.6

History Node

0.1.5

History Node

0.1.4

History Node

0.1.3

History Node

0.1.2

History Node

0.1.1

Download files

Download the file for your platform. If you're not sure which to choose, learn more about installing packages.

Filename, size & hash SHA256 hash help File type Python version Upload date
squeeze-0.1.7.tar.gz (18.1 MB) Copy SHA256 hash SHA256 Source None Mar 26, 2012

Supported by

Elastic Elastic Search Pingdom Pingdom Monitoring Google Google BigQuery Sentry Sentry Error logging CloudAMQP CloudAMQP RabbitMQ AWS AWS Cloud computing Fastly Fastly CDN DigiCert DigiCert EV certificate StatusPage StatusPage Status page