StonPy
StonPy is a package that allows users to store SBGN maps into a Neo4j database, query the database, and convert query results back to valid SBGN maps.
Installation
StonPy can be installed using pip:
pip install stonpy
Quickstart
from stonpy.core import STON
ston = STON("URI", "USER", "PASSWORD")
ston.create_map(sbgn_map="my_sbgn_file.sbgn", map_id="my_map_id")
my_query = """
MATCH (m:Map {id: 'my_map_id'})-[r:HAS_GLYPH]->(p:StoichiometricProcess)
RETURN p
"""
sbgn_files = ston.query_to_sbgn_file(
query=my_query,
sbgn_file="my_query_result.sbgn",
complete=True,
merge_records=False
)
print(sbgn_files)
Documentation
A complete documentation is available here.
Metadata
Release files for stonpy 0.2.1
For a detailed explanation of source distributions (sdists) and built distributions (wheels), please see the package formats documentation.
Source distribution (sdist)
| File | Size | Uploaded | Provenance | Actions |
|---|---|---|---|---|
| stonpy-0.2.1.tar.gz | 2.4 MB | Without provenance | Details for stonpy-0.2.1.tar.gz |
Built distribution (wheel)
| File | Interpreter | ABI | Platform | Actions Reset |
|---|---|---|---|---|
| stonpy-0.2.1-py3-none-any.whl | Python 3 | none | any | Details for stonpy-0.2.1-py3-none-any.whl |
Total release size: 4.8 MB
Release files / stonpy-0.2.1.tar.gz
| Download URL | stonpy-0.2.1.tar.gz |
|---|---|
| Size | 2.4 MB |
| Tags | Source |
|
SHA-256 checksum How to use checksums |
41e3cdc5b296fab3f7789ed5f896ad86086dbd8c8ecc99e225fff02174ebc825
|
|
BLAKE2b-256 checksum How to use checksums |
3cefb4e32fa6b02827d33a922dae1c3357cb0754ef7cae9e9d752710f247af14
|
| Upload date | |
|
Uploaded using Trusted Publishing? What is trusted publishing? |
No |
| Uploaded via |
twine/4.0.1 CPython/3.10.9
|
Release files / stonpy-0.2.1-py3-none-any.whl
| Download URL | stonpy-0.2.1-py3-none-any.whl |
|---|---|
| Size | 2.4 MB |
| Tags | Python 3 |
|
SHA-256 checksum How to use checksums |
ceef57caf97dc983b943bec2a157e9a33b1cf15267307e564895145fb9e2edac
|
|
BLAKE2b-256 checksum How to use checksums |
05d9ce20bdfec54ef5a9110eadb481d77d3d187f713864e4054c37056a05ede6
|
| Upload date | |
|
Uploaded using Trusted Publishing? What is trusted publishing? |
No |
| Uploaded via |
twine/4.0.1 CPython/3.10.9
|
Security for stonpy 0.2.1
Provenance
Provenance describes where a file came from. On PyPI, provenance is shared via attestations, which provide a verifiable record of the build or publishing details. View details, limitations and caveats.
No provenance found
None of the files in this release were uploaded with provenance metadata.
A note on package security
PyPI is a repository for distributing packages, not a service for auditing them. While third-party security researchers and our staff do their best to detect and remove malicious packages, PyPI cannot guarantee the quality, security or suitability of any given package.
To learn more about protecting yourself from malicious actors, visit our package security documentation.