Skip to main content

Voigt Profile Fitting in Python

Project description

Absorption line fitting implemented in Python.

If you use this software, please cite my paper on arXiv.

Installation

Dependencies

Python version 2.7 (Python 3 is not supported yet)

VoigtFit depends on matplotlib, numpy, scipy, h5py, astropy, and lmfit. You can install these using your favorite Python package manager such as conda or pip.

Using pip

The easiest way to install the most recent stable version of VoigtFit is using pip:

pip install VoigtFit

If you encounter the following AttributeError when attempting to install via pip:

AttributeError: ‘NoneType’ object has no attribute ‘splitlines’

Try running pip with the --upgrade option:

pip install --upgrade VoigtFit

From source

Alternatively, you can get the latest version of the source by cloning the git repository:

git clone https://github.com/jkrogager/VoigtFit.git

Once you’ve downloaded the source, you can navigate into the root source directory and run:

python setup.py install

If you encounter any problems, do not hesitate to raise an issue here.

Further documentation and how to use it

Check out the documentation for instructions of installation and use.

Project details


Download files

Download the file for your platform. If you're not sure which to choose, learn more about installing packages.

Filename, size & hash SHA256 hash help File type Python version Upload date
VoigtFit-0.9.10-py27-none-any.whl (2.5 MB) Copy SHA256 hash SHA256 Wheel py27
VoigtFit-0.9.10.tar.gz (2.5 MB) Copy SHA256 hash SHA256 Source None

Supported by

Elastic Elastic Search Pingdom Pingdom Monitoring Google Google BigQuery Sentry Sentry Error logging AWS AWS Cloud computing DataDog DataDog Monitoring Fastly Fastly CDN SignalFx SignalFx Supporter DigiCert DigiCert EV certificate StatusPage StatusPage Status page