Skip to main content
Archived

This project has been archived by its maintainers, and is no longer receiving any updates.

rtd pypi-v pypi-pyversions pypi-l tests codecov black

What is aioquic_mitmproxy?

aioquic_mitmproxy is a fork of aioquic, that is specifically targeted towards mitmproxy.

If you want to use QUIC and/or HTTP/3 in your Python project, you should use aioquic instead: https://pypi.org/project/aioquic/

Any code contributions to aioquic should also be submitted directly to upstream: https://github.com/aiortc/aioquic

What is aioquic?

aioquic is a library for the QUIC network protocol in Python. It features a minimal TLS 1.3 implementation, a QUIC stack and an HTTP/3 stack.

QUIC was standardised in RFC 9000 and HTTP/3 in RFC 9114. aioquic is regularly tested for interoperability against other QUIC implementations.

To learn more about aioquic please read the documentation.

Why should I use aioquic?

aioquic has been designed to be embedded into Python client and server libraries wishing to support QUIC and / or HTTP/3. The goal is to provide a common codebase for Python libraries in the hope of avoiding duplicated effort.

Both the QUIC and the HTTP/3 APIs follow the “bring your own I/O” pattern, leaving actual I/O operations to the API user. This approach has a number of advantages including making the code testable and allowing integration with different concurrency models.

Features

  • QUIC stack conforming with RFC 9000

  • HTTP/3 stack conforming with RFC 9114

  • minimal TLS 1.3 implementation conforming with RFC 8446

  • IPv4 and IPv6 support

  • connection migration and NAT rebinding

  • logging TLS traffic secrets

  • logging QUIC events in QLOG format

  • HTTP/3 server push support

Requirements

aioquic requires Python 3.8 or better.

Running the examples

aioquic comes with a number of examples illustrating various QUIC usecases.

You can browse these examples here: https://github.com/aiortc/aioquic/tree/main/examples

License

aioquic is released under the BSD license.

Metadata

Release files for aioquic-mitmproxy 0.9.21.1

For a detailed explanation of source distributions (sdists) and built distributions (wheels), please see the package formats documentation.

Source distribution (sdist)

Source distribution for aioquic-mitmproxy 0.9.21.1
File Size Uploaded
aioquic_mitmproxy-0.9.21.1.tar.gz 154.8 kB Details

Built distribution (wheel)

Table of built distributions (wheels) for aioquic-mitmproxy 0.9.21.1
File Interpreter ABI Platform
aioquic_mitmproxy-0.9.21.1-py3-none-any.whl Python 3 none any Details

Total release size: 234.5 kB

Release files / aioquic_mitmproxy-0.9.21.1.tar.gz

Download URL aioquic_mitmproxy-0.9.21.1.tar.gz
Size 154.8 kB
Tags Source
SHA-256 checksum
How to use checksums
0da539b95982dd02d1f971344215da5c15d0c409e2639d267a2815cd27335e26
BLAKE2b-256 checksum
How to use checksums
bebfa802df237a25ab61ec5ed5ab199f26e7c63bca110557e7c8a6c6f1415bc8
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
Yes
Uploaded via twine/4.0.2 CPython/3.11.6

Release files / aioquic_mitmproxy-0.9.21.1-py3-none-any.whl

Download URL aioquic_mitmproxy-0.9.21.1-py3-none-any.whl
Size 79.7 kB
Tags Python 3
SHA-256 checksum
How to use checksums
4c691232cc97f7c01c1677f21e2457523ee6780c4b5ad7d7936f6a3210d4f886
BLAKE2b-256 checksum
How to use checksums
7cb03b745ad3650adeeb72aa0c51fb1565d55457bcbb9d19ebb1047996779d02
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
Yes
Uploaded via twine/4.0.2 CPython/3.11.6
Anthropic, PBC Visionary sponsor Bloomberg Visionary sponsor Hudson River Trading Visionary sponsor Meta Visionary sponsor NVIDIA Visionary sponsor Microsoft Sustainability sponsor Depot Continuous Integration AWS Cloud computing and Security Sponsor Datadog Monitoring Fastly CDN Google Download Analytics Sentry Error logging StatusPage Status page