Skip to main content

Provider for Apache Airflow. Implements apache-airflow-providers-opsgenie package

Project description

Package apache-airflow-providers-opsgenie

Release: 4.0.0

Opsgenie

Provider package

This is a provider package for opsgenie provider. All classes for this provider package are in airflow.providers.opsgenie python package.

You can find package information and changelog for the provider in the documentation.

Installation

You can install this package on top of an existing Airflow 2 installation (see Requirements below for the minimum Airflow version supported) via pip install apache-airflow-providers-opsgenie

The package supports the following python versions: 3.7,3.8,3.9,3.10

Requirements

PIP package Version required
apache-airflow >=2.2.0
opsgenie-sdk >=2.1.5

Changelog

4.0.0

Breaking changes

3.1.0

Features

  • Add 'OpsgenieDeleteAlertOperator' (#23405)

Bug Fixes

  • Opsgenie: Fix 'close_alert' to properly send 'kwargs' (#23442)

3.0.3

Bug Fixes

  • Fix mistakenly added install_requires for all providers (#22382)

3.0.2

Misc

  • Add Trove classifiers in PyPI (Framework :: Apache Airflow :: Provider)

3.0.1

Misc

  • Support for Python 3.10

3.0.0

Breaking changes

OpsgenieAlertHook constructor does not take additional arguments or keyword arguments anymore. Changed the return type of OpsgenieAlertHook.get_conn to return an opsgenie_sdk.AlertApi object instead of a requests.Session object. Removed the OpsegnieAlertHook.execute method and replaced it with OpsegnieAlertHook.create_alert it now returns an opsgenie_sdk.SuccessResponse object instead of an Any type. OpsgenieAlertHook now takes visible_to instead of visibleTo key in the payload. OpsgenieAlertHook now takes request_id instead of requestId key in the payload.

  • Add 'OpsgenieCloseAlertOperator' (#20488)
  • Organize Opsgenie provider classes (#20454)
  • rewrite opsgenie alert hook with official python sdk, related issue #18641 (#20263)
  • Rename 'OpsgenieAlertOperator' to 'OpsgenieCreateAlertOperator' (#20514)

2.0.1

Misc

  • Optimise connection importing for Airflow 2.2.0

2.0.0

Breaking changes

  • Auto-apply apply_default decorator (#15667)

Warning

Due to apply_default decorator removal, this version of the provider requires Airflow 2.1.0+. If your Airflow version is < 2.1.0, and you want to install this provider version, first upgrade Airflow to at least version 2.1.0. Otherwise your Airflow package version will be upgraded automatically and you will have to manually run airflow upgrade db to complete the migration.

Bug Fixes

  • Fix hooks extended from http hook (#16109)

1.0.2

Bug Fixes

  • Fix type hints in OpsgenieAlertOperator (#14637)

1.0.1

Updated documentation and readme files.

1.0.0

Initial version of the provider.

Download files

Download the file for your platform. If you're not sure which to choose, learn more about installing packages.

Source Distribution

apache-airflow-providers-opsgenie-4.0.0.tar.gz (14.6 kB view hashes)

Uploaded source

Built Distribution

Supported by

AWS AWS Cloud computing Datadog Datadog Monitoring Facebook / Instagram Facebook / Instagram PSF Sponsor Fastly Fastly CDN Google Google Object Storage and Download Analytics Huawei Huawei PSF Sponsor Microsoft Microsoft PSF Sponsor NVIDIA NVIDIA PSF Sponsor Pingdom Pingdom Monitoring Salesforce Salesforce PSF Sponsor Sentry Sentry Error logging StatusPage StatusPage Status page