Extra command line tools for rdflib
This package provides some additional command line tools for rdflib:
- SPARQL Query execution with optional reasoning using OWL-RL:
rdflib-xtl sparql --help
- OWL Reasoning using OWL-RL
rdflib-xtl reason --help
Usage examples:
# Install pipx
pip3 install --user --upgrade pipx
# (optionally) clear pipx cache if you want the latest version ...
\rm -vr ~/.local/pipx/.cache/
# check version
pipx run --spec aucampia.rdflib-xtl rdflib-xtl --version
# Run SPARQL without reasoning ...
pipx run --spec aucampia.rdflib-xtl \
rdflib-xtl sparql \
-q 'SELECT * WHERE { ?s rdfs:subClassOf owl:Thing. }' \
http://xmlns.com/foaf/spec/index.rdf
# Dump input graph with SPARQL query ...
pipx run --spec aucampia.rdflib-xtl \
rdflib-xtl sparql \
-q 'CONSTRUCT { ?s ?p ?o } WHERE { ?s ?p ?o }' \
http://xmlns.com/foaf/spec/index.rdf
# Run SPARQL with reasoning ...
pipx run --spec aucampia.rdflib-xtl \
rdflib-xtl sparql --reason \
-q 'SELECT * WHERE { ?s rdfs:subClassOf owl:Thing. }' \
http://xmlns.com/foaf/spec/index.rdf
# Dump reasoned graph with SPARQL query ...
pipx run --spec aucampia.rdflib-xtl \
rdflib-xtl sparql --reason \
-q 'CONSTRUCT { ?s ?p ?o } WHERE { ?s ?p ?o }' \
http://xmlns.com/foaf/spec/index.rdf
# Run reasoning ...
pipx run --spec aucampia.rdflib-xtl \
rdflib-xtl reason http://xmlns.com/foaf/spec/index.rdf
Metadata
Release files for aucampia.rdflib-xtl 0.6.0
For a detailed explanation of source distributions (sdists) and built distributions (wheels), please see the package formats documentation.
Source distribution (sdist)
| File | Size | Uploaded | |
|---|---|---|---|
| aucampia.rdflib-xtl-0.6.0.tar.gz | 5.4 kB | Details |
Built distribution (wheel)
| File | Interpreter | ABI | Platform | Reset |
|---|---|---|---|---|
| aucampia.rdflib_xtl-0.6.0-py3-none-any.whl | Python 3 | none | any | Details |
Total release size: 11.1 kB
Release files / aucampia.rdflib-xtl-0.6.0.tar.gz
| Download URL | aucampia.rdflib-xtl-0.6.0.tar.gz |
|---|---|
| Size | 5.4 kB |
| Tags | Source |
|
SHA-256 checksum How to use checksums |
db4c65ef68d65da65d3099b003a2b694419248c2b30b696504493bc322268009
|
|
BLAKE2b-256 checksum How to use checksums |
73bfb7dee1d8568ec7b8336c80831d8a82be6bc73b241b71f76d5be36a642a4a
|
| Upload date | |
|
Uploaded using Trusted Publishing? What is trusted publishing? |
No |
| Uploaded via |
poetry/1.1.11 CPython/3.7.12 Linux/5.4.109+
|
Release files / aucampia.rdflib_xtl-0.6.0-py3-none-any.whl
| Download URL | aucampia.rdflib_xtl-0.6.0-py3-none-any.whl |
|---|---|
| Size | 5.7 kB |
| Tags | Python 3 |
|
SHA-256 checksum How to use checksums |
291be71fbfa219ebe5a94f325e6682522352d2e6ba3f96eaef97a56f8f92d175
|
|
BLAKE2b-256 checksum How to use checksums |
da10b0587fe586b0fb4ab0b564d9acab19ec9ee643474278109125579125b8e0
|
| Upload date | |
|
Uploaded using Trusted Publishing? What is trusted publishing? |
No |
| Uploaded via |
poetry/1.1.11 CPython/3.7.12 Linux/5.4.109+
|