Skip to main content

Python library to integrate axe and selenium for web accessibility testing.

Project description

axe-selenium-python integrates aXe and selenium to enable automated web accessibility testing.

License PyPI Issues

Requirements

You will need the following prerequisites in order to use pytest-html:

  • Python 2.7 or 3.6
  • pytest-selenium >= 3.0.0

Installation

To install axe-selenium-python:

$ pip install axe-selenium-python

Resources

CHANGELOG

version 0.0.21

  • Fixed include of aXe API file and references to it
  • Updated README

Project details


Download files

Download the file for your platform. If you're not sure which to choose, learn more about installing packages.

Filename, size & hash SHA256 hash help File type Python version Upload date
axe_selenium_python-0.0.269-py2.py3-none-any.whl (62.1 kB) Copy SHA256 hash SHA256 Wheel py2.py3
axe-selenium-python-0.0.269.tar.gz (66.2 kB) Copy SHA256 hash SHA256 Source None

Supported by

Elastic Elastic Search Pingdom Pingdom Monitoring Google Google BigQuery Sentry Sentry Error logging AWS AWS Cloud computing DataDog DataDog Monitoring Fastly Fastly CDN SignalFx SignalFx Supporter DigiCert DigiCert EV certificate StatusPage StatusPage Status page