Skip to main content

Check catkin packages for common errors

Project description

github_release pypi_badge debian_badge ci_badge codecov_master

catkin_lint checks package configurations for the catkin build system of ROS.

I generally recommend that you install catkin_lint from my Ubuntu PPA or use the pre-built packages for your Linux distribution. Use the PyPI version if your distribution does not ship catkin_lint or you absolutely need the latest release. The version in the ROS Package Archives is updated only once in a while.

You can find more information about catkin_lint in the online documentation and the available command line arguments on the manpage.

Project details


Download files

Download the file for your platform. If you're not sure which to choose, learn more about installing packages.

Files for catkin-lint, version 1.6.16
Filename, size File type Python version Upload date Hashes
Filename, size catkin_lint-1.6.16.tar.gz (554.7 kB) File type Source Python version None Upload date Hashes View
Filename, size catkin_lint-1.6.16-py2.py3-none-any.whl (62.1 kB) File type Wheel Python version py2.py3 Upload date Hashes View

Supported by

AWS AWS Cloud computing Datadog Datadog Monitoring Facebook / Instagram Facebook / Instagram PSF Sponsor Fastly Fastly CDN Google Google Object Storage and Download Analytics Huawei Huawei PSF Sponsor Microsoft Microsoft PSF Sponsor NVIDIA NVIDIA PSF Sponsor Pingdom Pingdom Monitoring Salesforce Salesforce PSF Sponsor Sentry Sentry Error logging StatusPage StatusPage Status page