Skip to main content

A material design web UI for deluge

Project description

CloudBreak - Material UI for Deluge

Build Status Screenshot

Requirements

  • Python 3 & pip
  • Libtorrent & Libtorrent python bindings
  • Deluge 2.0.0
pip3 install deluge==2.0.0
  • NodeJS 12 or greater & NPM

Building from source

  • Install deluge and libtorrent
  • Install dependencies
pip3 install -r requirements.txt
  • Install frontend dependencies
cd frontend
npm install
  • Build frontend
npm run build

Project details


Download files

Download the file for your platform. If you're not sure which to choose, learn more about installing packages.

Files for cloudbreak, version 0.1.1
Filename, size & hash File type Python version Upload date
cloudbreak-0.1.1-py3-none-any.whl (571.0 kB) View hashes Wheel py3

Supported by

Elastic Elastic Search Pingdom Pingdom Monitoring Google Google BigQuery Sentry Sentry Error logging AWS AWS Cloud computing DataDog DataDog Monitoring Fastly Fastly CDN SignalFx SignalFx Supporter DigiCert DigiCert EV certificate StatusPage StatusPage Status page