e-shop-graph (Python bindings)
Zero-copy e-commerce product knowledge graph. Extracts products from real-world
e-commerce HTML (platform JSON, __NEXT_DATA__, microdata, JSON-LD), builds a
zero-copy rkyv graph, and serves single-digit-ms read-only Cypher.
import esg
# Build from in-memory HTML strings -> graph.bin
n_bytes = esg.build_graph(["<html>...</html>", "<html>...</html>"], "graph.bin")
# Memory-bounded build: mmap each *.html in a dir, one at a time
n_pages, n_bytes = esg.build_graph_from_dir("/path/to/html_dir", "graph.bin")
# Run Cypher against a saved graph (zero-copy mmap)
rows = esg.query("graph.bin", "MATCH (p:Product) RETURN p.name LIMIT 5")
for row in rows:
print(row) # {"p.name": "..."}
esg is a pure graph engine: callers supply input and output paths; tenancy
and path semantics are the caller's concern.
Licensed under MIT OR Apache-2.0.
Metadata
Release files for e-shop-graph 0.8.6
For a detailed explanation of source distributions (sdists) and built distributions (wheels), please see the package formats documentation.
Built distributions (wheels)
| File | Reset | |||
|---|---|---|---|---|
| e_shop_graph-0.8.6-cp38-abi3-win_amd64.whl | CPython 3.8 | abi3 | Windows x86-64 | Details |
| e_shop_graph-0.8.6-cp38-abi3-manylinux_2_17_x86_64.manylinux2014_x86_64.whl | CPython 3.8 | abi3 | Linux glibc 2.17+ x86-64 | Details |
| e_shop_graph-0.8.6-cp38-abi3-manylinux_2_17_aarch64.manylinux2014_aarch64.whl | CPython 3.8 | abi3 | Linux glibc 2.17+ ARM64 | Details |
| e_shop_graph-0.8.6-cp38-abi3-macosx_11_0_arm64.whl | CPython 3.8 | abi3 | macOS 11.0+ ARM64 | Details |
| e_shop_graph-0.8.6-cp38-abi3-macosx_10_12_x86_64.whl | CPython 3.8 | abi3 | macOS 10.12+ x86-64 | Details |
Total release size: 6.0 MB
Release files / e_shop_graph-0.8.6-cp38-abi3-win_amd64.whl
| Download URL | e_shop_graph-0.8.6-cp38-abi3-win_amd64.whl |
|---|---|
| Size | 996.6 kB |
| Tags | CPython 3.8 Windows x86-64 abi3 |
|
SHA-256 checksum How to use checksums |
b1dcf639871f7beb55283b3b2b2b38c8aaa3d6ecdb97486cb9970014a344dc38
|
|
BLAKE2b-256 checksum How to use checksums |
d3f9b886ce35d3b08625078f39b7a31e7dde60bd2acf05f0c7b7630766ec4f05
|
| Upload date | |
|
Uploaded using Trusted Publishing? What is trusted publishing? |
Yes |
| Uploaded via |
twine/6.1.0 CPython/3.12.9
|
Provenance
Provenance describes where a file came from. On PyPI, provenance is shared via attestations, which provide a verifiable record of the build or publishing details. View details, limitations and caveats.
PyPI Publish Attestation
PyPI verified that this artifact, at this checksum, originated from the publisher listed below.
Signed by GitHub Actions, verified by PyPI on Jun 18, 2026.
Transparency logRelease files / e_shop_graph-0.8.6-cp38-abi3-manylinux_2_17_x86_64.manylinux2014_x86_64.whl
| Download URL | e_shop_graph-0.8.6-cp38-abi3-manylinux_2_17_x86_64.manylinux2014_x86_64.whl |
|---|---|
| Size | 1.3 MB |
| Tags | CPython 3.8 Linux glibc 2.17+ x86-64 abi3 |
|
SHA-256 checksum How to use checksums |
1896f19e638c9e96bf711ac42039675385c720a68a944d853e0724a6d3d01a2d
|
|
BLAKE2b-256 checksum How to use checksums |
e89817eaf9a40d537d101c634d56267d8f2808f3f1c071c152210a142aa95ace
|
| Upload date | |
|
Uploaded using Trusted Publishing? What is trusted publishing? |
Yes |
| Uploaded via |
twine/6.1.0 CPython/3.12.9
|
Provenance
Provenance describes where a file came from. On PyPI, provenance is shared via attestations, which provide a verifiable record of the build or publishing details. View details, limitations and caveats.
PyPI Publish Attestation
PyPI verified that this artifact, at this checksum, originated from the publisher listed below.
Signed by GitHub Actions, verified by PyPI on Jun 18, 2026.
Transparency logRelease files / e_shop_graph-0.8.6-cp38-abi3-manylinux_2_17_aarch64.manylinux2014_aarch64.whl
| Download URL | e_shop_graph-0.8.6-cp38-abi3-manylinux_2_17_aarch64.manylinux2014_aarch64.whl |
|---|---|
| Size | 1.3 MB |
| Tags | CPython 3.8 Linux glibc 2.17+ ARM64 abi3 |
|
SHA-256 checksum How to use checksums |
8adb7346c0a23d7785b935ff0d4dd85469c29e083ca33193aefce77a4454b343
|
|
BLAKE2b-256 checksum How to use checksums |
17f952e488eb37b1ecaa3a994cb7cc3c4ea764e1f817b25bd84e214cb526e4d3
|
| Upload date | |
|
Uploaded using Trusted Publishing? What is trusted publishing? |
Yes |
| Uploaded via |
twine/6.1.0 CPython/3.12.9
|
Provenance
Provenance describes where a file came from. On PyPI, provenance is shared via attestations, which provide a verifiable record of the build or publishing details. View details, limitations and caveats.
PyPI Publish Attestation
PyPI verified that this artifact, at this checksum, originated from the publisher listed below.
Signed by GitHub Actions, verified by PyPI on Jun 18, 2026.
Transparency logRelease files / e_shop_graph-0.8.6-cp38-abi3-macosx_11_0_arm64.whl
| Download URL | e_shop_graph-0.8.6-cp38-abi3-macosx_11_0_arm64.whl |
|---|---|
| Size | 1.1 MB |
| Tags | CPython 3.8 abi3 macOS 11.0+ ARM64 |
|
SHA-256 checksum How to use checksums |
4e010858f8b615396bcfbd8d23efdb20bcc842fea47f86842a595c8ed91c0924
|
|
BLAKE2b-256 checksum How to use checksums |
e300cf83bfed3eb5b6825b5b2d19c7cef86cb19c774dda26d0242153f4e86dd3
|
| Upload date | |
|
Uploaded using Trusted Publishing? What is trusted publishing? |
Yes |
| Uploaded via |
twine/6.1.0 CPython/3.12.9
|
Provenance
Provenance describes where a file came from. On PyPI, provenance is shared via attestations, which provide a verifiable record of the build or publishing details. View details, limitations and caveats.
PyPI Publish Attestation
PyPI verified that this artifact, at this checksum, originated from the publisher listed below.
Signed by GitHub Actions, verified by PyPI on Jun 18, 2026.
Transparency logRelease files / e_shop_graph-0.8.6-cp38-abi3-macosx_10_12_x86_64.whl
| Download URL | e_shop_graph-0.8.6-cp38-abi3-macosx_10_12_x86_64.whl |
|---|---|
| Size | 1.2 MB |
| Tags | CPython 3.8 abi3 macOS 10.12+ x86-64 |
|
SHA-256 checksum How to use checksums |
4c1190ed763f250b0ca4d2b91b5e01e10d5d03a07f1b8db4b2d6ab1d2df4d99f
|
|
BLAKE2b-256 checksum How to use checksums |
251e6e1ba8f6fe27b1a0af4dd34bb6c513c1c79df8e188a98d6683f03a6fa21b
|
| Upload date | |
|
Uploaded using Trusted Publishing? What is trusted publishing? |
Yes |
| Uploaded via |
twine/6.1.0 CPython/3.12.9
|
Provenance
Provenance describes where a file came from. On PyPI, provenance is shared via attestations, which provide a verifiable record of the build or publishing details. View details, limitations and caveats.
PyPI Publish Attestation
PyPI verified that this artifact, at this checksum, originated from the publisher listed below.
Signed by GitHub Actions, verified by PyPI on Jun 18, 2026.
Transparency log