fieldz_kb
A library to store dataclass-like objects into knowledge bases.
Features
- Multiple backends — Neo4j, FalkorDB, FalkorDBLite (embedded), clingo/ASP
- Automatic type conversion — primitives, collections, enums, nested dataclasses
- Plugin-based extensibility — add support for custom types
- BioCypher integration — generate BioCypher-compatible nodes, relationships, and YAML schemas
Installation
pip install fieldz-kb[neo4j] # Neo4j support
pip install fieldz-kb[falkordb] # FalkorDB support
pip install fieldz-kb[falkordblite] # FalkorDBLite (embedded) support
pip install fieldz-kb[clingo] # Clingo/ASP support
pip install fieldz-kb[biocypher] # BioCypher adapter
pip install fieldz-kb[all] # Everything
Quick example
import dataclasses
import fieldz_kb.lpg.session
import fieldz_kb.lpg.backends.neo4j
@dataclasses.dataclass
class Gene:
name: str
chromosome: int
backend = fieldz_kb.lpg.backends.neo4j.Neo4jBackend(
hostname="localhost",
username="neo4j",
password="password",
)
with fieldz_kb.lpg.session.Session(backend) as session:
session.save_from_object(Gene(name="TP53", chromosome=17))
results = session.execute_query_as_objects(
"MATCH (n:Gene) RETURN n"
)
Documentation
Full documentation is available at https://adrienrougny.github.io/fieldz_kb/.
License
GPLv3. See LICENSE for details.
Metadata
Release files for fieldz-kb 0.4.1
For a detailed explanation of source distributions (sdists) and built distributions (wheels), please see the package formats documentation.
Source distribution (sdist)
| File | Size | Uploaded | Provenance | Actions |
|---|---|---|---|---|
| fieldz_kb-0.4.1.tar.gz | 102.4 kB | With provenance | Details for fieldz_kb-0.4.1.tar.gz |
Built distribution (wheel)
| File | Interpreter | ABI | Platform | Actions Reset |
|---|---|---|---|---|
| fieldz_kb-0.4.1-py3-none-any.whl | Python 3 | none | any | Details for fieldz_kb-0.4.1-py3-none-any.whl |
Total release size: 130.8 kB
Release files / fieldz_kb-0.4.1.tar.gz
| Download URL | fieldz_kb-0.4.1.tar.gz |
|---|---|
| Size | 102.4 kB |
| Tags | Source |
|
SHA-256 checksum How to use checksums |
69f99e8dcdf2f5f1c9403cb7ddd0259616f395fa597da7e11af36a21bdc2c404
|
|
BLAKE2b-256 checksum How to use checksums |
e0592b0ae138112e3f87ae00250a5078b4dadb1530bbeeced75d66892f61e6ad
|
| Upload date | |
|
Uploaded using Trusted Publishing? What is trusted publishing? |
Yes |
| Uploaded via |
twine/7.0.0 CPython/3.13.14
|
Provenance
Provenance describes where a file came from. On PyPI, provenance is shared via attestations, which provide a verifiable record of the build or publishing details. View details, limitations and caveats.
PyPI Publish Attestation
PyPI verified that this artifact, at this checksum, originated from the publisher listed below.
Signed by GitHub Actions, verified by PyPI on Aug 21, 2026.
Transparency logRelease files / fieldz_kb-0.4.1-py3-none-any.whl
| Download URL | fieldz_kb-0.4.1-py3-none-any.whl |
|---|---|
| Size | 28.4 kB |
| Tags | Python 3 |
|
SHA-256 checksum How to use checksums |
f77a2e13ade763e22d2a7607ae5e6bb561171acdeac32d700f36aadfa29b02c4
|
|
BLAKE2b-256 checksum How to use checksums |
0a46c654e3f81282ad36022e50e1b1da0c857e12c64cb623570ab7616d89e9c4
|
| Upload date | |
|
Uploaded using Trusted Publishing? What is trusted publishing? |
Yes |
| Uploaded via |
twine/7.0.0 CPython/3.13.14
|
Provenance
Provenance describes where a file came from. On PyPI, provenance is shared via attestations, which provide a verifiable record of the build or publishing details. View details, limitations and caveats.
PyPI Publish Attestation
PyPI verified that this artifact, at this checksum, originated from the publisher listed below.
Signed by GitHub Actions, verified by PyPI on Aug 21, 2026.
Transparency logSecurity for fieldz-kb 0.4.1
Provenance
Provenance describes where a file came from. On PyPI, provenance is shared via attestations, which provide a verifiable record of the build or publishing details. View details, limitations and caveats.
Full provenance
All 2 files in this release have been uploaded with provenance metadata.
Attestation for fieldz_kb-0.4.1.tar.gz
PyPI Publish Attestation
PyPI verified that this artifact, at this checksum, originated from the publisher listed below.
Signed by GitHub Actions, verified by PyPI on Aug 21, 2026.
Transparency logA note on package security
PyPI is a repository for distributing packages, not a service for auditing them. While third-party security researchers and our staff do their best to detect and remove malicious packages, PyPI cannot guarantee the quality, security or suitability of any given package.
To learn more about protecting yourself from malicious actors, visit our package security documentation.