Skip to main content

Python bindings for Gameboy Core

Project description

https://travis-ci.org/nnarain/gameboycore-python.svg?branch=master https://ci.appveyor.com/api/projects/status/hatnihg8ii76hc27?svg=true https://img.shields.io/pypi/v/gameboycore.svg https://readthedocs.org/projects/gameboycore-python/badge/?version=latest

Python Bindings for GameboyCore

Installation

On Windows:

pip install gameboycore

On Linux:

git clone https://github.com/nnarain/gameboycore-python cd gameboycore-python

pip install -e .

Linux uses a source installation because PyPi does not accept .whl files and pip cannot install .egg files.

See online docs for installation from source instructions.

Supported Python Versions

Python Windows Linux
2.7 Soon Yes
3.3 Soon Yes
3.4 Soon Yes
3.5 Yes Yes
3.6 Yes Yes

GameboyCore Python does not currently support Python version 2.7 - 3.4 on Windows since Visual Studio 9/10 do not support C++11.

Project details


Download files

Download the file for your platform. If you're not sure which to choose, learn more about installing packages.

Filename, size & hash SHA256 hash help File type Python version Upload date
gameboycore-0.5.3-cp35-cp35m-win32.whl (123.5 kB) Copy SHA256 hash SHA256 Wheel 3.5
gameboycore-0.5.3-cp35-cp35m-win_amd64.whl (153.4 kB) Copy SHA256 hash SHA256 Wheel 3.5
gameboycore-0.5.3-cp36-cp36m-win32.whl (123.5 kB) Copy SHA256 hash SHA256 Wheel 3.6
gameboycore-0.5.3-cp36-cp36m-win_amd64.whl (153.4 kB) Copy SHA256 hash SHA256 Wheel 3.6
gameboycore-0.5.3.tar.gz (153.4 kB) Copy SHA256 hash SHA256 Source None

Supported by

Elastic Elastic Search Pingdom Pingdom Monitoring Google Google BigQuery Sentry Sentry Error logging AWS AWS Cloud computing DataDog DataDog Monitoring Fastly Fastly CDN SignalFx SignalFx Supporter DigiCert DigiCert EV certificate StatusPage StatusPage Status page