Skip to main content

OEREBlex geoLink Formatter

Project description

Changelog

2.0.1 (current dev)

Supported GEO-Link API versions: v1.0.0, v1.1.0, v1.1.1, v1.2.0, v1.2.1, v1.2.2 (default)

  • Add support for GEO-Link API version 1.2.2 (new attribute “index”)
  • Dependency updates

2.0.0

Supported GEO-Link API versions: v1.0.0, v1.1.0, v1.1.1, v1.2.0, v1.2.1 (default)

  • Add support for GEO-Link API version 1.2.1 (new attribute “municipality”)
  • Drop support for Python 2
  • Dependency updates

1.5.4

Supported GEO-Link API versions: v1.0.0, v1.1.0, v1.1.1, v1.2.0 (default)

  • Use GitHub Actions instead of Travis
  • Dependency updates

1.5.3

Supported GEO-Link API versions: v1.0.0, v1.1.0, v1.1.1, v1.2.0 (default)

  • Fix decoding error for schema version 1.2.0

1.5.2

Supported GEO-Link API versions: v1.0.0, v1.1.0, v1.1.1, v1.2.0 (default)

  • Parse schema only if validation is enabled
  • Dependency updates

1.5.1

Supported GEO-Link API versions: v1.0.0, v1.1.0, v1.1.1, v1.2.0 (default)

  • Add missing enumeration values for federal level in schema

1.5.0

Supported GEO-Link API versions: v1.0.0, v1.1.0, v1.1.1, v1.2.0 (default)

  • Add support for GEO-Link API version 1.2.0
  • New document attribute ‘language’
  • New doctype ‘notice’
  • Files now have descriptions as well as titles, using the description for display where possible

1.4.0

Supported GEO-Link API versions: v1.0.0, v1.1.0, v1.1.1 (default)

  • Add test for arbitrary URL parameters
  • Add enumeration value “Bezirk” for attribute “federal_level”
  • If available, show abrogation date instead of files in HTML output
  • Add additional attributes in schema (approval_date, publication_date and cycle)

1.3.2

Supported GEO-Link API versions: v1.0.0, v1.1.0, v1.1.1 (default)

  • Move repository to GitHub openoereb
  • Use defusedxml for XML parsing
  • Drop support for Python 3.4

1.3.1

Supported GEO-Link API versions: v1.0.0, v1.1.0, v1.1.1 (default)

  • Add support for GEO-Link API version 1.1.1

1.3.0

Supported GEO-Link API versions: v1.0.0, v1.1.0 (default)

  • Add support for multiple GEO-Link API versions

1.2.0

Supported GEO-Link API versions: 20171108 (v1.1.0)

  • Use new GEO-Link API

1.1.2

Supported GEO-Link API version: 20170214 (v1.0.0)

  • All attributes are optional, as defined in the schema

1.1.1

Supported GEO-Link API version: 20170214 (v1.0.0)

  • Allow documents with empty file list

1.1.0

Supported GEO-Link API version: 20170214 (v1.0.0)

  • Add support for Python 3

1.0.0

Supported GEO-Link API version: 20170214 (v1.0.0)

  • Initial version

Project details


Download files

Download the file for your platform. If you're not sure which to choose, learn more about installing packages.

Source Distribution

geolink_formatter-2.0.1.tar.gz (11.0 kB view hashes)

Uploaded source

Built Distribution

geolink_formatter-2.0.1-py2.py3-none-any.whl (14.2 kB view hashes)

Uploaded py2 py3

Supported by

AWS AWS Cloud computing Datadog Datadog Monitoring Facebook / Instagram Facebook / Instagram PSF Sponsor Fastly Fastly CDN Google Google Object Storage and Download Analytics Huawei Huawei PSF Sponsor Microsoft Microsoft PSF Sponsor NVIDIA NVIDIA PSF Sponsor Pingdom Pingdom Monitoring Salesforce Salesforce PSF Sponsor Sentry Sentry Error logging StatusPage StatusPage Status page