Skip to main content

Google Cloud API client core library

Project description

pypi versions

This library is not meant to stand-alone. Instead it defines common helpers (e.g. base Client classes) used by all of the google-cloud-* packages.

Quick Start

$ pip install --upgrade google-cloud-core

For more information on setting up your Python development environment, such as installing pip and virtualenv on your system, please refer to Python Development Environment Setup Guide for Google Cloud Platform.

Supported Python Versions

Python >= 3.7

Unsupported Python Versions

Python == 2.7: the last version of this library which supported Python 2.7 is google.cloud.core 1.7.2.

Python == 3.6: the last version of this library which supported Python 3.6 is google.cloud.core 2.3.1.

Project details


Download files

Download the file for your platform. If you're not sure which to choose, learn more about installing packages.

Source Distribution

google-cloud-core-2.3.2.tar.gz (35.2 kB view hashes)

Uploaded source

Built Distribution

google_cloud_core-2.3.2-py2.py3-none-any.whl (30.0 kB view hashes)

Uploaded py2 py3

Supported by

AWS AWS Cloud computing Datadog Datadog Monitoring Facebook / Instagram Facebook / Instagram PSF Sponsor Fastly Fastly CDN Google Google Object Storage and Download Analytics Huawei Huawei PSF Sponsor Microsoft Microsoft PSF Sponsor NVIDIA NVIDIA PSF Sponsor Pingdom Pingdom Monitoring Salesforce Salesforce PSF Sponsor Sentry Sentry Error logging StatusPage StatusPage Status page