This release is a pre-release and may not be stable for production use.
Apache TinkerPop - Gremlin Python
Apache TinkerPop™ is a graph computing framework for both graph databases (OLTP) and graph analytic systems (OLAP). Gremlin is the graph traversal language of TinkerPop. It can be described as a functional, data-flow language that enables users to succinctly express complex traversals on (or queries of) their application’s property graph.
Gremlin-Python implements Gremlin within the Python language and can be used on any Python virtual machine including the popular CPython machine. Python’s syntax has the same constructs as Java including “dot notation” for function chaining (a.b.c), round bracket function arguments (a(b,c))`, and support for global namespaces (a(b()) vs a(__.b()))`. As such, anyone familiar with Gremlin-Java will immediately be able to work with Gremlin-Python. Moreover, there are a few added constructs to Gremlin-Python that make traversals a bit more succinct.
>>> g.V().both()[1:3].toList() [v[2], v[4]] >>> g.V().both()[1].toList() [v[2]] >>> g.V().both().name.toList() [lop, vadas, josh, marko, marko, josh, peter, ripple, lop, marko, josh, lop]
Please see the reference documentation at Apache TinkerPop for more information on usage.
Metadata
Release files for gremlinpython 3.2.4.dev1478023292
For a detailed explanation of source distributions (sdists) and built distributions (wheels), please see the package formats documentation.
Source distribution (sdist)
| File | Size | Uploaded | Provenance | Actions |
|---|---|---|---|---|
| gremlinpython-3.2.4.dev1478023292.tar.gz | 19.7 kB | Without provenance | Details for gremlinpython-3.2.4.dev1478023292.tar.gz |
Built distribution (wheel)
| File | Interpreter | ABI | Platform | Actions Reset |
|---|---|---|---|---|
| gremlinpython-3.2.4.dev1478023292-py2.py3-none-any.whl | Python 3, Python 2 | none | any | Details for gremlinpython-3.2.4.dev1478023292-py2.py3-none-any.whl |
Total release size: 52.0 kB
Release files / gremlinpython-3.2.4.dev1478023292.tar.gz
| Download URL | gremlinpython-3.2.4.dev1478023292.tar.gz |
|---|---|
| Size | 19.7 kB |
| Tags | Source |
|
SHA-256 checksum How to use checksums |
8291fbb08de5f6f7f42e57ed2411ad4ba542ba3556f10f4d55ab5d7f57a61504
|
|
BLAKE2b-256 checksum How to use checksums |
2c0017f4bbabbcbe812179ea821ee33ae5f56e14e9c5ee622816dff2301683d3
|
| Upload date | |
|
Uploaded using Trusted Publishing? What is trusted publishing? |
No |
Release files / gremlinpython-3.2.4.dev1478023292-py2.py3-none-any.whl
| Download URL | gremlinpython-3.2.4.dev1478023292-py2.py3-none-any.whl |
|---|---|
| Size | 32.3 kB |
| Tags | Python 2 Python 3 |
|
SHA-256 checksum How to use checksums |
82518742720f32c3683218ac0154382707de77170980504ac153649ef0e55e92
|
|
BLAKE2b-256 checksum How to use checksums |
c8bd18f1f26e1e2908362ad27923137685ca2c5b3b14ba0f18cfb43e7fab68b6
|
| Upload date | |
|
Uploaded using Trusted Publishing? What is trusted publishing? |
No |
Security for gremlinpython 3.2.4.dev1478023292
Provenance
Provenance describes where a file came from. On PyPI, provenance is shared via attestations, which provide a verifiable record of the build or publishing details. View details, limitations and caveats.
No provenance found
None of the files in this release were uploaded with provenance metadata.
A note on package security
PyPI is a repository for distributing packages, not a service for auditing them. While third-party security researchers and our staff do their best to detect and remove malicious packages, PyPI cannot guarantee the quality, security or suitability of any given package.
To learn more about protecting yourself from malicious actors, visit our package security documentation.