httoop
An object oriented HTTP/1.1 library. (HTTP/2 will probably follow in the future).
Httoop can be used to parse, compose and work with HTTP-Request- and Response-Messages.
It is an generic library for implementing HTTP servers, clients, caches and proxies.
Httoop provides an powerful interface using the vocabularity used in RFC 7230 - 7235 and focuses on implementing HTTP "compliant" as defined in RFC 7230 Section 2.5.
"An implementation is not compliant if it fails to satisfy one or more of the MUST or REQUIRED level requirements for the protocols it implements." RFC 2616 Section 1.2
On top of the object oriented abstraction of HTTP httoop provides an easy way to support WSGI.
HTTP and extensions are defined in the following RFC's:
-
HTTP/1.1 RFC 7234 Caching
-
HTTP/2 RFC 7540 Hypertext Transfer Protocol Version 2
-
HTTP/2 RFC 7541 HPACK: Header Compression for HTTP/2
-
RFC 5987 Character Set and Language Encoding for Hypertext Transfer Protocol (HTTP) Header Field Parameters
-
Uniform Resource Identifier (URI) (RFC 3986)
-
HTTP Digest Access Authentication (RFC 7616)
-
The 'Basic' HTTP Authentication Scheme (RFC 7617)
-
Additional HTTP Status Codes (RFC 6585)
-
Forwarded HTTP Extension RFC 7239
-
Prefer Header for HTTP RFC 7240
-
PATCH Method for HTTP (RFC 5789)
-
JavaScript Object Notation (JSON) Patch (RFC 6902)
-
The HTTP QUERY Method (RFC 10008)
-
Use of the Content-Disposition Header Field in the Hypertext Transfer Protocol (HTTP) (RFC 6266)
-
Upgrading to TLS Within HTTP/1.1 (RFC 2817)
-
Transparent Content Negotiation in HTTP (RFC 2295)
-
HTTP Remote Variant Selection Algorithm -- RVSA/1.0 (RFC 2296)
-
HTTP State Management Mechanism (RFC 6265)
-
Same-site Cookies (Draft 7)
-
HTTP Extensions for Web Distributed Authoring and Versioning (WebDAV) (RFC 4918)
-
Hyper Text Coffee Pot Control Protocol (HTCPCP/1.0) (RFC 2324)
Extended information about hypermedia, WWW and how HTTP is meant to be used:
-
Web Linking (RFC 5988)
-
Representational State Transfer REST
-
Clarifications of misconceptions people have about REST:
OAuth 2.0:
- OAuth Working Group Specifications
- OAuth 2.0 Security Best Current Practice
- The OAuth 2.0 Authorization Framework
- Bearer Token Usage
- JSON Web Token (JWT)
- JSON Web Token (JWT) Profile for OAuth 2.0 Access Tokens
- Resource Indicators for OAuth 2.0
Obsolete:
- HTTP/1.1 RFC 7230 Message Syntax and Routing
- HTTP/1.1 RFC 7231 Semantics and Content
- HTTP/1.1 RFC 7232 Conditional Requests
- HTTP/1.1 RFC 7233 Range Requests
- HTTP/1.1 RFC 7235 Authentication
- Hypertext Transfer Protocol -- HTTP/1.1 (RFC 2616)
- HTTP Authentication: Basic and Digest Access Authentication (RFC 2617)
- HTTP Authentication-Info and Proxy-Authentication-Info Response Header Fields (RFC 7615)
Metadata
Release files for httoop 0.2.1
For a detailed explanation of source distributions (sdists) and built distributions (wheels), please see the package formats documentation.
Source distribution (sdist)
| File | Size | Uploaded | |
|---|---|---|---|
| httoop-0.2.1.tar.gz | 65.1 kB | Details |
Built distribution (wheel)
| File | Interpreter | ABI | Platform | Reset |
|---|---|---|---|---|
| httoop-0.2.1-py3-none-any.whl | Python 3 | none | any | Details |
Total release size: 146.9 kB
Release files / httoop-0.2.1.tar.gz
| Download URL | httoop-0.2.1.tar.gz |
|---|---|
| Size | 65.1 kB |
| Tags | Source |
|
SHA-256 checksum How to use checksums |
a90746fc37a40ad534f3ecb43c4fd02422f55c1be98946750c2f6c39ec0278d9
|
|
BLAKE2b-256 checksum How to use checksums |
12a603ce8a478feda8aa675ce49e3e02056a66cfff12e5b8b718e880403b708a
|
| Upload date | |
|
Uploaded using Trusted Publishing? What is trusted publishing? |
Yes |
| Uploaded via |
twine/7.0.0 CPython/3.13.14
|
Provenance
Provenance describes where a file came from. On PyPI, provenance is shared via attestations, which provide a verifiable record of the build or publishing details. View details, limitations and caveats.
PyPI Publish Attestation
PyPI verified that this artifact, at this checksum, originated from the publisher listed below.
Signed by GitHub Actions, verified by PyPI on Aug 19, 2026.
Transparency logRelease files / httoop-0.2.1-py3-none-any.whl
| Download URL | httoop-0.2.1-py3-none-any.whl |
|---|---|
| Size | 81.7 kB |
| Tags | Python 3 |
|
SHA-256 checksum How to use checksums |
a7c8e4b45e93fe59f02c3cc54068360e832ba8dafa75a297aade1fd36776baed
|
|
BLAKE2b-256 checksum How to use checksums |
5c8fac95926a21d370f779ff0683a5ba9685da330f547d68cb3daca1e312ade9
|
| Upload date | |
|
Uploaded using Trusted Publishing? What is trusted publishing? |
Yes |
| Uploaded via |
twine/7.0.0 CPython/3.13.14
|
Provenance
Provenance describes where a file came from. On PyPI, provenance is shared via attestations, which provide a verifiable record of the build or publishing details. View details, limitations and caveats.
PyPI Publish Attestation
PyPI verified that this artifact, at this checksum, originated from the publisher listed below.
Signed by GitHub Actions, verified by PyPI on Aug 19, 2026.
Transparency log