Skip to main content
Pre-release

This release is a pre-release and may not be stable for production use.

IssunDB for Python

Python version PyPI version Documentation Examples License

The Python bindings for IssunDB.

Installation

pip install --pre issundb

Quickstart

import json

from issundb import IssunDB

# Open or create a database
db = IssunDB("./issundb-data")

# Add two nodes (with properties)
alice = db.add_node("Person", json.dumps({"name": "Alice", "age": 30}))
bob = db.add_node("Person", json.dumps({"name": "Bob", "age": 28}))

# Add a directed edge between the nodes
db.add_edge(alice, bob, "KNOWS", json.dumps({"since": 2021}))

# Run a Cypher query and print the results
result = json.loads(
    db.query("MATCH (a:Person)-[r:KNOWS]->(b:Person) RETURN a.name, b.name, r.since")
)

print(result["columns"])
for record in result["records"]:
    print(record["values"])
# Output:
['a.name', 'b.name', 'r.since']
['Alice', 'Bob', 2021]

Documentation

Visit IssunDB's documentation for detailed information including examples and API references.

License

The contents of this directory are available under either of these licenses:

Metadata

Release files for issundb 0.1.0a30

For a detailed explanation of source distributions (sdists) and built distributions (wheels), please see the package formats documentation.

Built distributions (wheels)

Table of built distributions (wheels) for issundb 0.1.0a30
File Actions
issundb-0.1.0a30-cp310-abi3-win_amd64.whl CPython 3.10 abi3 Windows x86-64 Details for issundb-0.1.0a30-cp310-abi3-win_amd64.whl
issundb-0.1.0a30-cp310-abi3-manylinux_2_28_x86_64.whl CPython 3.10 abi3 Linux glibc 2.28+ x86-64 Details for issundb-0.1.0a30-cp310-abi3-manylinux_2_28_x86_64.whl
issundb-0.1.0a30-cp310-abi3-manylinux_2_28_aarch64.whl CPython 3.10 abi3 Linux glibc 2.28+ ARM64 Details for issundb-0.1.0a30-cp310-abi3-manylinux_2_28_aarch64.whl
issundb-0.1.0a30-cp310-abi3-macosx_11_0_arm64.whl CPython 3.10 abi3 macOS 11.0+ ARM64 Details for issundb-0.1.0a30-cp310-abi3-macosx_11_0_arm64.whl

Total release size: 29.2 MB

Release files / issundb-0.1.0a30-cp310-abi3-win_amd64.whl

Download URL issundb-0.1.0a30-cp310-abi3-win_amd64.whl
Size 7.7 MB
Tags CPython 3.10 Windows x86-64 abi3
SHA-256 checksum
How to use checksums
e03bb2cfa2704348612307b9b382122ba1ce7eeed817b3821d49ae413531144e
BLAKE2b-256 checksum
How to use checksums
2f94415456442816b9d9ca2dc157bfe88b648373656b2ed1a66e08279047c7d6
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
No
Uploaded via twine/7.0.0 CPython/3.10.21

Release files / issundb-0.1.0a30-cp310-abi3-manylinux_2_28_x86_64.whl

Download URL issundb-0.1.0a30-cp310-abi3-manylinux_2_28_x86_64.whl
Size 8.3 MB
Tags CPython 3.10 Linux glibc 2.28+ x86-64 abi3
SHA-256 checksum
How to use checksums
13ab6633bf59f0d5f6065a81ba6c72a9c3bdb3ac92e809946c74a12caaacbf01
BLAKE2b-256 checksum
How to use checksums
a83f74d740a6ff32d757edf3c4f2f716caefee911988169153126667ae0f60f3
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
No
Uploaded via twine/7.0.0 CPython/3.10.21

Release files / issundb-0.1.0a30-cp310-abi3-manylinux_2_28_aarch64.whl

Download URL issundb-0.1.0a30-cp310-abi3-manylinux_2_28_aarch64.whl
Size 7.2 MB
Tags CPython 3.10 Linux glibc 2.28+ ARM64 abi3
SHA-256 checksum
How to use checksums
57c886ffeb8ae767d86075386c04e5e202e354fe3cb6171ac81e4c2689bcf13f
BLAKE2b-256 checksum
How to use checksums
e75024bf159f6f9efa9b5f11ae84f35de49f6f4a913815d27ee89ffa93e0dcd9
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
No
Uploaded via twine/7.0.0 CPython/3.10.21

Release files / issundb-0.1.0a30-cp310-abi3-macosx_11_0_arm64.whl

Download URL issundb-0.1.0a30-cp310-abi3-macosx_11_0_arm64.whl
Size 6.1 MB
Tags CPython 3.10 abi3 macOS 11.0+ ARM64
SHA-256 checksum
How to use checksums
58523c70249fe0520ae2a50fe6193a51d030fac82d7248700f0d8e0080501a0c
BLAKE2b-256 checksum
How to use checksums
52ddb0ee0718e4fe9a3d92f2ba373572767d552fe9fccdd7a65bc9c35861ad00
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
No
Uploaded via twine/7.0.0 CPython/3.10.21

Security for issundb 0.1.0a30

Provenance

Provenance describes where a file came from. On PyPI, provenance is shared via attestations, which provide a verifiable record of the build or publishing details. View details, limitations and caveats.

No provenance found

None of the files in this release were uploaded with provenance metadata.

A note on package security

PyPI is a repository for distributing packages, not a service for auditing them. While third-party security researchers and our staff do their best to detect and remove malicious packages, PyPI cannot guarantee the quality, security or suitability of any given package.

To learn more about protecting yourself from malicious actors, visit our package security documentation.

Release history Release notifications | RSS feed

This release
Anthropic, PBC Visionary sponsor Bloomberg Visionary sponsor Hudson River Trading Visionary sponsor Meta Visionary sponsor NVIDIA Visionary sponsor Microsoft Sustainability sponsor Depot Continuous Integration AWS Cloud computing and Security Sponsor Datadog Monitoring Fastly CDN Google Download Analytics Sentry Error logging StatusPage Status page