Skip to main content

Python interface to iTerm2's scripting API

Project description

iTerm2 3.1 has a new scripting API. It uses Google Protocol Buffers to allow programs written in any language to communicate with iTerm2. Most users will prefer an interface in a high-level language. This library offers a Python interface to iTerm2. Please note that Prefs > Advanced > Enable websocket API server must be enabled in iTerm2 for this library to work.

Project details


Download files

Download the file for your platform. If you're not sure which to choose, learn more about installing packages.

Files for iterm2, version 1.2
Filename, size & hash File type Python version Upload date
iterm2-1.2-py3-none-any.whl (124.2 kB) View hashes Wheel py3
iterm2-1.2.tar.gz (109.4 kB) View hashes Source None

Supported by

Elastic Elastic Search Pingdom Pingdom Monitoring Google Google BigQuery Sentry Sentry Error logging AWS AWS Cloud computing DataDog DataDog Monitoring Fastly Fastly CDN SignalFx SignalFx Supporter DigiCert DigiCert EV certificate StatusPage StatusPage Status page