kinesyslog
Syslog and GELF relay to AWS Kinesis Firehose. Supports UDP, TCP, and TLS; RFC3164, RFC5424, RFC5425, RFC6587, GELF v1.1.
Prerequisites
This module requires Python 3.5 or better, due to its use of the asyncio framework.
This module uses Boto3 to make API calls against the Kinesis Firehose service. You should have a working AWS API environment (~/.aws/credentials, environment variables, or EC2 IAM Role) that allows calling Kinesis Firehose’s put-record-batch method against the stream specified on the command line.
Consult README.md on GitHub for usage instructions.
Metadata
Release files for kinesyslog 2.0.1
For a detailed explanation of source distributions (sdists) and built distributions (wheels), please see the package formats documentation.
Built distribution (wheel)
| File | Interpreter | ABI | Platform | Reset |
|---|---|---|---|---|
| kinesyslog-2.0.1-py2.py3-none-any.whl | Python 2, Python 3 | none | any | Details |
Release files / kinesyslog-2.0.1-py2.py3-none-any.whl
| Download URL | kinesyslog-2.0.1-py2.py3-none-any.whl |
|---|---|
| Size | 28.9 kB |
| Tags | Python 2 Python 3 |
|
SHA-256 checksum How to use checksums |
caaf74e3fcb83a2a0a1e0888698802e2c006a5a08fc78e6bc544dfb2e03e7f55
|
|
BLAKE2b-256 checksum How to use checksums |
bd93bd2fb33fbe4d421a10bbb41630056367e3a2364a4c801cef3aa4fd1599d9
|
| Upload date | |
|
Uploaded using Trusted Publishing? What is trusted publishing? |
No |
| Uploaded via |
twine/1.12.1 pkginfo/1.4.2 requests/2.21.0 setuptools/40.4.3 requests-toolbelt/0.8.0 tqdm/4.28.1 CPython/3.6.7+
|