⅃arqL 🐦✨
larql is a simple Lark parser for SPARQL 1.1.
Apart from parsing SPARQL strings into Lark parse trees, the only additional feature larql will provide is a lark.Transformer for (pretty) serializing parsed queries back to strings. That's it.
WARNING: This project is in an early stage of development and should be used with caution.
Usage
from larql import SPARQLParser
parsed = SPARQLParser("select * where {?s ?p ?o .}")
parsed.tree # lark.Tree
# not yet available
parsed.serialize(indent=2)
Metadata
Release files for larql 0.1.0
For a detailed explanation of source distributions (sdists) and built distributions (wheels), please see the package formats documentation.
Source distribution (sdist)
| File | Size | Uploaded | |
|---|---|---|---|
| larql-0.1.0.tar.gz | 2.0 MB | Details |
Built distribution (wheel)
| File | Interpreter | ABI | Platform | Reset |
|---|---|---|---|---|
| larql-0.1.0-py3-none-any.whl | Python 3 | none | any | Details |
Total release size: 2.0 MB
Release files / larql-0.1.0.tar.gz
| Download URL | larql-0.1.0.tar.gz |
|---|---|
| Size | 2.0 MB |
| Tags | Source |
|
SHA-256 checksum How to use checksums |
53f1abff5db6b4d28837217a4c615861f7007fc3c9c1bf6ebfdb06608e4263f1
|
|
BLAKE2b-256 checksum How to use checksums |
e2d80a27c9a083da4a270dfa06d68a2daa04014001b8fe9b306b63d388c5503b
|
| Upload date | |
|
Uploaded using Trusted Publishing? What is trusted publishing? |
No |
| Uploaded via |
uv/0.5.22
|
Release files / larql-0.1.0-py3-none-any.whl
| Download URL | larql-0.1.0-py3-none-any.whl |
|---|---|
| Size | 7.0 kB |
| Tags | Python 3 |
|
SHA-256 checksum How to use checksums |
967dd1ac2e06f14d6f30810816058760d328316bc961f937dd945e4975c8bc45
|
|
BLAKE2b-256 checksum How to use checksums |
2f0972dac41dd943dc0e432cc0ca7e18c8d2dd25b315c06717e4424d32e595a6
|
| Upload date | |
|
Uploaded using Trusted Publishing? What is trusted publishing? |
No |
| Uploaded via |
uv/0.5.22
|