momapy_kb
A library to integrate SBGN and CellDesigner maps into graph databases and logic programs.
This library relies on momapy for handling maps.
Features
- Multiple Labelled Property Graph backends: save maps in a Neo4j, FalkorDB or FalkorDBLite (embedded) database
- A Clingo/ASP backend: convert maps to logic programming facts
- Collection management: organize maps into named collections
- Layout element queries: query model elements and retrieve corresponding layout elements for rendering
Installation
pip install momapy-kb[neo4j] # Neo4j support
pip install momapy-kb[falkordb] # FalkorDB support
pip install momapy-kb[falkordblite] # FalkorDBLite (embedded) support
pip install momapy-kb[clingo] # Clingo/ASP support
pip install momapy-kb[all] # Everything
Quick example
import momapy_kb.lpg.session
import momapy_kb.lpg.backends.neo4j
backend = momapy_kb.lpg.backends.neo4j.Neo4jBackend(
hostname="localhost",
username="neo4j",
password="password",
)
with momapy_kb.lpg.session.Session(backend) as session:
# save a CellDesigner map to the Neo4j database
session.save_from_file("model.xml", integration_mode="hash")
# query model elements, return them as momapy objects
results = session.execute_query_as_objects(
"MATCH (n:Protein) RETURN n"
)
# query model elements, return corresponding layout elements
layout_results = session.execute_query_as_layout_elements(
"MATCH (n:Reaction) RETURN n"
)
Documentation
Full documentation is available at https://adrienrougny.github.io/momapy_kb/.
Metadata
Release files for momapy-kb 0.5.0
For a detailed explanation of source distributions (sdists) and built distributions (wheels), please see the package formats documentation.
Source distribution (sdist)
| File | Size | Uploaded | Provenance | Actions |
|---|---|---|---|---|
| momapy_kb-0.5.0.tar.gz | 285.7 kB | With provenance | Details for momapy_kb-0.5.0.tar.gz |
Built distribution (wheel)
| File | Interpreter | ABI | Platform | Actions Reset |
|---|---|---|---|---|
| momapy_kb-0.5.0-py3-none-any.whl | Python 3 | none | any | Details for momapy_kb-0.5.0-py3-none-any.whl |
Total release size: 316.6 kB
Release files / momapy_kb-0.5.0.tar.gz
| Download URL | momapy_kb-0.5.0.tar.gz |
|---|---|
| Size | 285.7 kB |
| Tags | Source |
|
SHA-256 checksum How to use checksums |
3f5977ebc5d05b19c0e6706b23830bcdf6c8f3a0dc7fd7a621df0cb458428e4f
|
|
BLAKE2b-256 checksum How to use checksums |
9b23b03c4ebe98b1b39df70513e90a06dd6d4dee1ea56b082f0edd92d8f07e56
|
| Upload date | |
|
Uploaded using Trusted Publishing? What is trusted publishing? |
Yes |
| Uploaded via |
twine/7.0.0 CPython/3.13.14
|
Provenance
Provenance describes where a file came from. On PyPI, provenance is shared via attestations, which provide a verifiable record of the build or publishing details. View details, limitations and caveats.
PyPI Publish Attestation
PyPI verified that this artifact, at this checksum, originated from the publisher listed below.
Signed by GitHub Actions, verified by PyPI on Sep 4, 2026.
Transparency logRelease files / momapy_kb-0.5.0-py3-none-any.whl
| Download URL | momapy_kb-0.5.0-py3-none-any.whl |
|---|---|
| Size | 30.9 kB |
| Tags | Python 3 |
|
SHA-256 checksum How to use checksums |
a2ab6c26866c7367335e106df427736d68d93f0297f82ca3b0c96f452781bc90
|
|
BLAKE2b-256 checksum How to use checksums |
8374644f85cbb5e5c29b2e9baec9b95886434424698125623814dc8a7a3150fb
|
| Upload date | |
|
Uploaded using Trusted Publishing? What is trusted publishing? |
Yes |
| Uploaded via |
twine/7.0.0 CPython/3.13.14
|
Provenance
Provenance describes where a file came from. On PyPI, provenance is shared via attestations, which provide a verifiable record of the build or publishing details. View details, limitations and caveats.
PyPI Publish Attestation
PyPI verified that this artifact, at this checksum, originated from the publisher listed below.
Signed by GitHub Actions, verified by PyPI on Sep 4, 2026.
Transparency logSecurity for momapy-kb 0.5.0
Provenance
Provenance describes where a file came from. On PyPI, provenance is shared via attestations, which provide a verifiable record of the build or publishing details. View details, limitations and caveats.
Full provenance
All 2 files in this release have been uploaded with provenance metadata.
Attestation for momapy_kb-0.5.0.tar.gz
PyPI Publish Attestation
PyPI verified that this artifact, at this checksum, originated from the publisher listed below.
Signed by GitHub Actions, verified by PyPI on Sep 4, 2026.
Transparency logA note on package security
PyPI is a repository for distributing packages, not a service for auditing them. While third-party security researchers and our staff do their best to detect and remove malicious packages, PyPI cannot guarantee the quality, security or suitability of any given package.
To learn more about protecting yourself from malicious actors, visit our package security documentation.