Skip to main content

Interactive data selection cursors for Matplotlib.

Project description

PyPI Read the Docs Travis CodeCov

mplcursors provides interactive data selection cursors for Matplotlib. It is inspired from mpldatacursor, with a much simplified API.

mplcursors requires Python 3, and Matplotlib≥2.1.

Read the documentation on readthedocs.org.

Install from PyPI with:

python -mpip install mplcursors

or from Github with:

python -mpip install git+https://github.com/anntzer/mplcursors

Run tests with pytest≥3.2.0.

Project details


Download files

Download the file for your platform. If you're not sure which to choose, learn more about installing packages.

Filename, size & hash SHA256 hash help File type Python version Upload date
mplcursors-0.2.1-py3-none-any.whl (17.9 kB) Copy SHA256 hash SHA256 Wheel py3 Sep 25, 2018
mplcursors-0.2.1.tar.gz (112.0 kB) Copy SHA256 hash SHA256 Source None Sep 25, 2018

Supported by

Elastic Elastic Search Pingdom Pingdom Monitoring Google Google BigQuery Sentry Sentry Error logging AWS AWS Cloud computing DataDog DataDog Monitoring Fastly Fastly CDN SignalFx SignalFx Supporter DigiCert DigiCert EV certificate StatusPage StatusPage Status page