NeoCortex
Docker Image for Neo4j / API Interface
docker-compose build
docker-compose up
Command Line Interface
Install neocortex
python setup.py install
Run commands by executing neo from the command line
>neo config create
Config file not found: C:/Users/tyler/neo.cfg
Run 'neo config create' to create a required configuration file.
? Create config file "C:/Users/tyler/neo.cfg" ? Yes
? Server: 127.0.0.1
? Server Port: 5800
? Username: admin
? Password: admin
Config written
>neo
Usage: neo [OPTIONS] COMMAND [ARGS]...
Options:
--debug Verbose printing
--config-path PATH Configuration file to use, default: "~/neo.cfg"
--help Show this message and exit.
Commands:
config View, edit, or create your configuration file
query Run queries agains the graph db
Accessing the Neo4j Graph DB
python setup.py develop
python
>>> from neocortex.api.client import NeoClient
>>> nc = NeoClient('admin','admin','192.168.99.100:5000')
>>> nc.query('MATCH (n) RETURN n')
[]
Metadata
Release files for neocortex 0.0.1
For a detailed explanation of source distributions (sdists) and built distributions (wheels), please see the package formats documentation.
Source distribution (sdist)
| File | Size | Uploaded | Provenance | |
|---|---|---|---|---|
| neocortex-0.0.1.tar.gz | 10.0 kB | Without provenance | Details |
Built distribution (wheel)
| File | Interpreter | ABI | Platform | Reset |
|---|---|---|---|---|
| neocortex-0.0.1-py3-none-any.whl | Python 3 | none | any | Details |
Total release size: 26.0 kB
Release files / neocortex-0.0.1.tar.gz
| Download URL | neocortex-0.0.1.tar.gz |
|---|---|
| Size | 10.0 kB |
| Tags | Source |
|
SHA-256 checksum How to use checksums |
2860f57150536a656ce7bd5e16dded0c5971e97d5a8b70d5e58f2248a557dba0
|
|
BLAKE2b-256 checksum How to use checksums |
3185bea7de61e638066a907db1c658f52db37939acea10316ab2358839a5b31e
|
| Upload date | |
|
Uploaded using Trusted Publishing? What is trusted publishing? |
No |
| Uploaded via |
twine/2.0.0 pkginfo/1.5.0.1 requests/2.22.0 setuptools/41.6.0 requests-toolbelt/0.9.1 tqdm/4.36.1 CPython/3.6.8
|
Release files / neocortex-0.0.1-py3-none-any.whl
| Download URL | neocortex-0.0.1-py3-none-any.whl |
|---|---|
| Size | 16.0 kB |
| Tags | Python 3 |
|
SHA-256 checksum How to use checksums |
5b64a72cdaa4251c6867acdc00cdeb06ce3598d1899ec78ef925437ae93f5123
|
|
BLAKE2b-256 checksum How to use checksums |
5637b70d27d4c11f0cc27705773f8e162cf97ac4c8256780a6695675a5936e2a
|
| Upload date | |
|
Uploaded using Trusted Publishing? What is trusted publishing? |
No |
| Uploaded via |
twine/2.0.0 pkginfo/1.5.0.1 requests/2.22.0 setuptools/41.6.0 requests-toolbelt/0.9.1 tqdm/4.36.1 CPython/3.6.8
|
Security for neocortex 0.0.1
Provenance
Provenance describes where a file came from. On PyPI, provenance is shared via attestations, which provide a verifiable record of the build or publishing details. View details, limitations and caveats.
No provenance found
None of the files in this release were uploaded with provenance metadata.
A note on package security
PyPI is a repository for distributing packages, not a service for auditing them. While third-party security researchers and our staff do their best to detect and remove malicious packages, PyPI cannot guarantee the quality, security or suitability of any given package.
To learn more about protecting yourself from malicious actors, visit our package security documentation.