Skip to main content

The ultimate Python library in building OAuth and OpenID Connect servers. JWS, JWK, JWA, JWT are included.

Specifications

  • RFC5849: The OAuth 1.0 Protocol

  • RFC6749: The OAuth 2.0 Authorization Framework

  • RFC6750: The OAuth 2.0 Authorization Framework: Bearer Token Usage

  • RFC7009: OAuth 2.0 Token Revocation

  • RFC7515: JSON Web Signature

  • RFC7516: JSON Web Encryption

  • RFC7517: JSON Web Key

  • RFC7518: JSON Web Algorithms

  • RFC7519: JSON Web Token

  • RFC7521: Assertion Framework for OAuth 2.0 Client Authentication and Authorization Grants

  • RFC7523: JSON Web Token (JWT) Profile for OAuth 2.0 Client Authentication and Authorization Grants

  • RFC7591: OAuth 2.0 Dynamic Client Registration Protocol

  • RFC7636: Proof Key for Code Exchange by OAuth Public Clients

  • RFC7638: JSON Web Key (JWK) Thumbprint

  • RFC7662: OAuth 2.0 Token Introspection

  • RFC8037: CFRG Elliptic Curve Diffie-Hellman (ECDH) and Signatures in JSON Object Signing and Encryption (JOSE)

  • RFC8414: OAuth 2.0 Authorization Server Metadata

  • RFC8628: OAuth 2.0 Device Authorization Grant

  • OpenID Connect 1.0

  • OpenID Connect Discovery 1.0

Implementations

  • Requests OAuth 1 Session

  • Requests OAuth 2 Session

  • Requests Assertion Session

  • HTTPX OAuth 1 Session

  • HTTPX OAuth 2 Session

  • HTTPX Assertion Session

  • Flask OAuth 1/2 Client

  • Django OAuth 1/2 Client

  • Starlette OAuth 1/2 Client

  • Flask OAuth 1.0 Server

  • Flask OAuth 2.0 Server

  • Flask OpenID Connect 1.0

  • Django OAuth 1.0 Server

  • Django OAuth 2.0 Server

  • Django OpenID Connect 1.0

License

Authlib is licensed under BSD. Please see LICENSE for licensing details.

If this license does not fit your company, consider to purchase a commercial license. Find more information on Authlib Plans.

Metadata

Release files for nevermined-authlib 0.1.0

For a detailed explanation of source distributions (sdists) and built distributions (wheels), please see the package formats documentation.

Source distribution (sdist)

Source distribution for nevermined-authlib 0.1.0
File Size Uploaded Provenance
nevermined-authlib-0.1.0.tar.gz 132.0 kB Without provenance Details

Built distribution (wheel)

Table of built distributions (wheels) for nevermined-authlib 0.1.0
File Interpreter ABI Platform
nevermined_authlib-0.1.0-py2.py3-none-any.whl Python 3, Python 2 none any Details

Total release size: 335.3 kB

Release files / nevermined-authlib-0.1.0.tar.gz

Download URL nevermined-authlib-0.1.0.tar.gz
Size 132.0 kB
Tags Source
SHA-256 checksum
How to use checksums
f75250a894e561f93daf779d95b76dca8bcc29f8f11c2078002b3659f9fbb6f5
BLAKE2b-256 checksum
How to use checksums
7fef6853d680c178e1b33841d93fe40184b75e13a894f922c72297bd99a1b2e2
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
No
Uploaded via twine/3.2.0 pkginfo/1.6.1 requests/2.25.0 setuptools/49.2.1 requests-toolbelt/0.9.1 tqdm/4.54.0 CPython/3.9.0

Release files / nevermined_authlib-0.1.0-py2.py3-none-any.whl

Download URL nevermined_authlib-0.1.0-py2.py3-none-any.whl
Size 203.3 kB
Tags Python 2 Python 3
SHA-256 checksum
How to use checksums
40e3d74b5e46acc04f47edfe3ceb873f390a19de04de451e33cf8397021ebfed
BLAKE2b-256 checksum
How to use checksums
ac169607749dfdee9e5c5cc471d40120dc77c7760e6b9fcd0eefd2a4e9dac81c
Upload date
Uploaded using Trusted Publishing?
What is trusted publishing?
No
Uploaded via twine/3.2.0 pkginfo/1.6.1 requests/2.25.0 setuptools/49.2.1 requests-toolbelt/0.9.1 tqdm/4.54.0 CPython/3.9.0

Security for nevermined-authlib 0.1.0

Provenance

Provenance describes where a file came from. On PyPI, provenance is shared via attestations, which provide a verifiable record of the build or publishing details. View details, limitations and caveats.

No provenance found

None of the files in this release were uploaded with provenance metadata.

A note on package security

PyPI is a repository for distributing packages, not a service for auditing them. While third-party security researchers and our staff do their best to detect and remove malicious packages, PyPI cannot guarantee the quality, security or suitability of any given package.

To learn more about protecting yourself from malicious actors, visit our package security documentation.

Release history Release notifications | RSS feed

This release

0.1.0 This release

2 release files No provenance

Anthropic, PBC Visionary sponsor Bloomberg Visionary sponsor Hudson River Trading Visionary sponsor Meta Visionary sponsor NVIDIA Visionary sponsor Microsoft Sustainability sponsor Depot Continuous Integration AWS Cloud computing and Security Sponsor Datadog Monitoring Fastly CDN Google Download Analytics Sentry Error logging StatusPage Status page